Closed Bug 1311783 Opened 3 years ago Closed 3 years ago

Pretty print firefox -h

Categories

(Toolkit :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: abspack, Assigned: abspack)

Details

Attachments

(1 file, 2 obsolete files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160920074044
Attached patch pretty_print.patch (obsolete) — Splinter Review
Attachment #8803047 - Flags: feedback?(jorgk)
Severity: normal → enhancement
OS: Unspecified → All
Hardware: Unspecified → All
Comment on attachment 8803047 [details] [diff] [review]
pretty_print.patch

Review of attachment 8803047 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, I like this. I tried thunderbird -help yesterday so check the text we're printing for -compose. I noticed a lot of dog's breakfast being printed.

The files in question are in M-C so you'd have to get a review from them. And the summary of the bug should be: Pretty print firefox -h. Have you tried that?
Attachment #8803047 - Flags: feedback?(jorgk) → feedback+
Summary: Pretty print thunderbird -h → Pretty print firefox -h
Attachment #8803047 - Flags: feedback+ → review?(benjamin)
Attachment #8803047 - Flags: review?(benjamin) → review+
Thanks for the review. We extended the command line option in Thunderbird and noticed that some M-C options don't look nice.
Assignee: nobody → abspack
Keywords: checkin-needed
Component: Untriaged → General
Product: Thunderbird → Toolkit
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/f53cc8d0a93c31769f44437ae39e0c8e75cba4ff
Backed out changeset 028b297ddba4 (Bug 1311783) for eslint failures. rs=bustage-fix
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Manuel, can you just shorten the lines in the JS file to less than 90 characters, so more "+"s.
Attached patch pretty_print.patch (obsolete) — Splinter Review
Attachment #8803047 - Attachment is obsolete: true
Specifically for the Ubuntu Thunderbird package I created this bug for pretty printing:
https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1636011
Comment on attachment 8804887 [details] [diff] [review]
pretty_print.patch

Sorry, can you r+ this again, it failed to land due to a long JS line.
Attachment #8804887 - Flags: review?(benjamin)
Is there a reason why the options from "thunderbird -h" are not listed when I type "man thunderbird"? I only get this:

THUNDERBIRD(1)              General Commands Manual             THUNDERBIRD(1)

NAME
       thunderbird  —   thunderbird  - Mail User Agent (MUA) and newsgroup/RSS
       client for X11 derived from the Mozilla suite.

SYNOPSIS
       thunderbird [-P profile]

DESCRIPTION
       Thunderbird provides IMAP/POP support, a built-in RSS  reader,  support
       for  HTML  mail,  powerful quick search, saved search folders, advanced
       message filtering, junk mail controls, message grouping, labels, return
       receipts, smart address book LDAP address completion, import tools, and
       the ability to  manage  multiple  identities  in  email  and  newsgroup
       accounts.   Thunderbird  provides enterprise and government grade secu‐
       rity such as S/MIME, digital signing, message encryption,  and  support
       for certificates and security devices.

OPTIONS
       -P profile
                 If  no profile is given to the -P option, the profile manager
                 will pop-up. You will be allowed to create or select  a  pro‐
                 file.  Thunderbird then launches with the selected profile.

SEE ALSO
       The Thunderbird Homepage:
       http://www.mozilla.org/projects/thunderbird/

       The Debian Thunderbird FAQ:
       http://www.jwsdot.com/debian/faq.html

                                                                THUNDERBIRD(1)
Mark or Dave, the eslint rules about line length are making this code much less readable. Can you suggest how we add an exception or format this so that the message is readable and passes the eslint checks?
Flags: needinfo?(standard8)
Flags: needinfo?(dtownsend)
Attachment #8804887 - Flags: review?(benjamin) → review-
(In reply to Benjamin Smedberg [:bsmedberg] from comment #12)
> Mark or Dave, the eslint rules about line length are making this code much
> less readable. Can you suggest how we add an exception or format this so
> that the message is readable and passes the eslint checks?

There's a couple of ways of doing it.

Per line:

  my very long line; // eslint-disable-line max-len

Per file:

  /* eslint-disable max-len */

Per section:

  /* eslint-disable max-len */
  my very long lines;
  my very long lines2;
  /* eslint-disable max-len */

If you really want to, you could just increase the overall max length for the file at the top of the file:

/* eslint max-len:1000 */

More details if you need them:

http://eslint.org/docs/user-guide/configuring#configuring-rules
http://eslint.org/docs/user-guide/configuring#disabling-rules-with-inline-comments
Flags: needinfo?(standard8)
Flags: needinfo?(dtownsend)
Thanks. Manuel, could you do a third patch, please, using one of the suggestions from comment #13.
Attachment #8804887 - Attachment is obsolete: true
Attachment #8805552 - Flags: review?(benjamin)
Attachment #8805552 - Flags: review?(benjamin) → review+
Review has been granted. Let's try to check in again.
That's right. The author has to 
- request this by setting the keyword "checkin-needed"
  so a sheriff will do it - or -
- land it himself if he has Level 3 access rights - or -
- get someone with those rights to do it for him.
  I have those rights but I don't land on Mozilla inbound, I only do C-*.
Keywords: checkin-needed
Okay, thanks for the info :)
https://hg.mozilla.org/mozilla-central/rev/bed4b65bc236
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.