All users were logged out of Bugzilla on October 13th, 2018

Duplicate TextLogSummaryLine rows

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jgraham, Assigned: jgraham)

Tracking

Details

Attachments

(2 attachments)

(Assignee)

Description

2 years ago
Presumably because we are managing to run crossreference_error_line more than once per job.

Steps to fix:

* Check for existing TextLogSummary before creating any error lines to prevent new bad data

* Correct existing bad data

* Add a unique constraint on text_log_summary_line.failure_line
Created attachment 8803125 [details] [review]
[treeherder] mozilla:summary_duplicate_1 > mozilla:production
(Assignee)

Updated

2 years ago
Attachment #8803125 - Flags: review?(wlachance)
Comment on attachment 8803125 [details] [review]
[treeherder] mozilla:summary_duplicate_1 > mozilla:production

See PR for comments but I think this is fine to go in as a stopgap
Attachment #8803125 - Flags: review?(wlachance) → review+
Created attachment 8803466 [details] [review]
[treeherder] mozilla:text_log_summary_dupe_remove > mozilla:master
(Assignee)

Updated

2 years ago
Attachment #8803466 - Flags: review?(wlachance)
Comment on attachment 8803466 [details] [review]
[treeherder] mozilla:text_log_summary_dupe_remove > mozilla:master

This looks reasonable to me, assuming it works. Feel free to carry forward r+ if you make minor modifications.
Attachment #8803466 - Flags: review?(wlachance) → review+

Comment 5

2 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/f769d2dbbc72a83f346d727cf02494fcbd357fba
Bug 1311840 - Bail if we try to run crossreference_error_lines on a job with an existing TextLogSummary (#1942)
Duplicate of this bug: 1311454

Comment 7

2 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/3f9c754c78c718f705dacf72465d65eaac3d3bc9
Bug 1311840 - Add temporary command to remove duplicate text_log_summary_line entries (#1946)

Updated

2 years ago
Assignee: nobody → james

Comment 8

2 years ago
Is this fixed?
Flags: needinfo?(james)
(Assignee)

Comment 9

2 years ago
It seems to be.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(james)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.