Native HTML5 video player not keyboard accessible

RESOLVED DUPLICATE of bug 494175

Status

()

Core
Untriaged
RESOLVED DUPLICATE of bug 494175
10 months ago
10 months ago

People

(Reporter: Joe Watkins, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.143 Safari/537.36

Steps to reproduce:

1. Open Firefox on Mac or Windows
2. Visit: http://s.codepen.io/joe-watkins/debug/kkzXBZ
3. Try to send focus to the video using only the keyboard
4. Try to send focus to any of the controls of the video player with only the keyboard


Actual results:

No visual focus is sent to the video or its controls making it not keyboard accessible.


Expected results:

Visual focus indicator is present when the video receives focus. The controls for the video player are also keyboard-friendly and operable by only using a keyboard.

Updated

10 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 494175
You need to log in before you can comment on or make changes to this bug.