Night mode increases brightness level if it's already low

VERIFIED FIXED

Status

()

Firefox for iOS
General
P3
normal
VERIFIED FIXED
a year ago
10 months ago

People

(Reporter: bunn, Assigned: lyang)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios7.0+, fxios-v6.0 affected)

Details

Attachments

(2 attachments)

2.75 MB, video/quicktime
Details
55 bytes, text/x-github-pull-request
sleroux
: review+
Details | Review | Splinter Review
(Reporter)

Description

a year ago
Created attachment 8803208 [details]
nightmode.mov

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160916101415

Steps to reproduce:

1 - Set the brightness level of your device to the lowest setting;
2 - Open Firefox settings;
3 - Select Night Mode;



Actual results:

- The brightness level of my device was increased;


Expected results:

- Night mode should *not* increase the brightness level at any circumstance. 
Proposed solution:
- If the brightness level is higher than the one set by night mode. Set night mode default level;
- If the brightness level is lower than the one set by night mode. Set night mode level to same level as the device.

(The video recorded does not display the brightness difference on the screen since it's recorded using quicktime, but it's possible to notice the difference on the brightness settings on iOS control center)
Status: UNCONFIRMED → NEW
status-fxios-v6.0: --- → affected
tracking-fxios: --- → ?
Ever confirmed: true
tracking-fxios: ? → 7.0+
Priority: -- → P3

Updated

11 months ago
Blocks: 1272237
(Assignee)

Comment 1

10 months ago
Created attachment 8827015 [details] [review]
pull request
Attachment #8827015 - Flags: review?(sleroux)

Updated

10 months ago
Assignee: nobody → lyang
Status: NEW → ASSIGNED
Comment on attachment 8827015 [details] [review]
pull request

LGTM - just a code nit.
Attachment #8827015 - Flags: review?(sleroux) → review+
(Assignee)

Comment 3

10 months ago
Comment on attachment 8827015 [details] [review]
pull request

Update
Attachment #8827015 - Flags: review+ → review?(sleroux)
LGTM - Thanks!

master https://github.com/mozilla-mobile/firefox-ios/commit/0786eeac4055409556ecc62041f553d263c6b931
Status: ASSIGNED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED

Updated

10 months ago
Attachment #8827015 - Flags: review?(sleroux) → review+

Comment 5

10 months ago
Verifying as fix on master 51abcc7c. 


Night mode should no longer increases the brightness level.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.