Closed Bug 1311925 Opened 3 years ago Closed 3 years ago

Fix background-color behavior of inspector-searchbox

Categories

(DevTools :: Inspector, defect, P2)

defect

Tracking

(firefox50 unaffected, firefox51 unaffected, firefox52 verified)

VERIFIED FIXED
Firefox 52
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- verified

People

(Reporter: magicp.jp, Assigned: ntim)

References

Details

(Keywords: regression)

Attachments

(3 files)

STR:
1. Start latest Nightly
2. Go to about:home
3. Open DevTools > Inspector
4. Type "bugzilla" in inspector-searchbox
5. Hit [Enter] key > result will be "No matches"
6. Click (x)icon for clearing input text

AR:
In step 4, background-color turns yellow
In step 5, background-color turns red (it is right behavior)
In step 6, background-color turns yellow

ER:
In step 4, don't change background-color in progress
In step 5, background-color turns red
In step 6, background-color turns default

Regression:
mozregression-gui got exception...
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=47be3ae8a710b35f040dffe7403877e764ab61ac&tochange=12a9cca092f816fabb67cc8a139e0cbd5b1cea37

Bug 1309577 ?
Blocks: 1309577
Has Regression Range: --- → yes
Has STR: --- → yes
Assignee: nobody → ntim.bugs
Keywords: regression
#inspector-searchbox should be excluded like below.

[devtools/client/themes/common.css] line 637

- .devtools-searchinput:-moz-any([filled],.filled),
+ .devtools-searchinput:not(#inspector-searchbox):-moz-any([filled],.filled),
.devtools-filterinput:-moz-any([filled],.filled) {
  background-color: var(--searchbox-background-color);
  border-color: var(--searchbox-border-color);
}
Sounds like a recent regression that needs to be addressed rather soon (so it lands in 52, or is at least uplifted to it if it lands later). So, P2, on this account.

Thank you Tim for taking this on!
Priority: -- → P2
The yellow highlight doesn't really make sense for search boxes as we don't need to communicate that content is hidden unlike filter boxes which filter out content. Helen agreed with the removal of the highlight on IRC.

I've also removed the code that sets the filled attribute for the inspector search, because it's unused, and it's also not being removed properly (hence this bug).
Comment on attachment 8807254 [details]
Bug 1311925 - Remove yellow highlight from search boxes.

https://reviewboard.mozilla.org/r/90484/#review90266
Attachment #8807254 - Flags: review?(gl) → review+
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/cb4ab44839fd
Remove yellow highlight from search boxes. r=gl
https://hg.mozilla.org/mozilla-central/rev/cb4ab44839fd
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
verified fixed in latest Nightly (20161105030211). Thanks!
Thanks!
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.