Java Plugin Error: INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
17 years ago
7 years ago

People

(Reporter: pedro.alves, Assigned: blackconnect)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Every time java has to be turned on, the browser locks up. Never happened in
prior versions (...,0.97,0.98). The version of jdk is 1.3.1, but the same think
happens with j2sdk1.4.0

Turning debugger on gives: 
INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory

Comment 1

17 years ago
I've encountered this problem and solved it (quite by accident) by symlinking to
the JRE plugin in the Java distribution directory instead of a copy of the same
file that I had been keeping in a subdirectory beneath the mozilla plugins
directory.

Could it be that some code is using the symlink as the base path to reach
another Java-related file that is present on that path only in the complete Java
install tree?

Comment 2

17 years ago
[root@system root]# /usr/lib/mozilla/mozilla-bin
INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory

URL: http://java.sun.com (or any with java content).
Running on AMD duron 800.
mozilla-0.9.9.  Installed using the RedHat 7.2 binary RPMs, and jre-1.3.1_02-fcs rpm
(Reporter)

Comment 3

17 years ago
Yes, making the symlink to the jre plugin solved the problem

Comment 4

17 years ago
Making the symlink worked for me as well.  Perhaps there could be something put
in the documentation about creating a symlink and NOT copying the file...

Comment 5

17 years ago
*** Bug 134850 has been marked as a duplicate of this bug. ***
Using:
    --------------
    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523
    --------------
unable to open:
    -------------------
    URL: http://java.sun.com 
    -------------------
I keep getting the following error:
    -----------------------------------------------------------
    $ mozilla -d
    INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
    <
    System error?:: No such file or directory
    Gdk-ERROR **: Fatal IO error 9 (Bad file descriptor) on X server :0.0.
    INTERNAL ERROR on Browser End: Could not read ack from browser
    System error?:: Resource temporarily unavailable
    $
    -----------------------------------------------------------


1- I got the problem with Mozilla 1.0 rc3 as obtained from:
http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.0rc3/Red_Hat_7x_RPMS/i386/

2- I also got the problem when trying to follow the 
   suggested workaround from:

 Comment #1 From D Wollmann 2002-03-15 22:30 -------
 http://bugzilla.mozilla.org/show_bug.cgi?id=131195#c1

   Note that I change mozilla's java "pluggins" to jdk1.4
   using SUN's latest J2SDK1.4 download
   (I can only get to the site using Mozilla 1.0 rc3 
    if I deactivate "java" going to:
    Edit->Preferences...
        Advanced->[enable/disable] Java )

DOWNLOADED "j2sdk-1_4_0-linux-i386-rpm.bin"
FROM: http://java.sun.com/j2se/1.4/download.html
sh j2sdk-1_4_0-linux-i386-rpm.bin
cd /usr/lib/mozilla/pluggins
rm -rf java2
cp -r /usr/java/j2sdk1.4.0/jre java2
rm libjavaplugin_oji.so
cp java2/plugin/i386/ns610/libjavaplugin_oji140.so .

but...

Still can't open (with Java Enabled)
URL: http://java.sun.com 

:(
OUPS...

Using a "real" "simlink" for java-jre 
Mozilla 1.0 rc3 can now go to the

URL: http://java.sun.com 

Note that I did not create a real "simlink" 
on my previous attempt !!!!!!!!!!!!!!!!!!!!!

Replace the command lines with these:

DOWNLOADED "j2sdk-1_4_0-linux-i386-rpm.bin"
FROM: http://java.sun.com/j2se/1.4/download.html
sh j2sdk-1_4_0-linux-i386-rpm.bin
cd /usr/lib/mozilla/pluggins
rm -rf java2
ln -s /usr/java/j2sdk1.4.0/jre java2
rm libjavaplugin_oji.so
ln -s /usr/java/j2sdk1.4.0/jre/plugin/i386/ns610/libjavaplugin_oji140.so .

NOW I CAN open (with Java Enabled)
URL: http://java.sun.com 

:)
Pedro Alves: can you still reproduce this with a recent Mozilla version (like
1.0RC3)? If not, mark this bug "worksforme"

Comment 9

17 years ago
the error still Occurs, and but been marked as duplicated of bug 134850... but I
consider it still open because it is not right that I need everytime to make a
symlink to java, and netscape6/7 doesn't require it, then netsape core
programmers know the workaround
eeh.. not Netscape knows a workaround, SUN places the Plugin in every folder
which could be a Netscape-Plugin-Folder. Install Mozilla to /usr/local/netscape
next time and the Plugin will install in the right place.
To quote the release notes: "Linux With tar.gz builds on Linux, after the JRE
has installed, put a symlink to java2/plugin/i386/ns610/libjava.oji.so in your
mozilla1.0 plugins/ directory."

Everyone so far to have this problem has confirmed that following the release
notes fixes it. 

In addition, there is also an easy installer at
http://wp.netscape.com/plugins/jvm.html --- also mentioned in the release notes,
I might add.

Based on this, resolving invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Component: Java-Implemented Plugins → Java-Implemented Plugins
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.