Closed Bug 1311960 Opened 3 years ago Closed 3 years ago

Turn on remote media decoding preference on Android.

Categories

(Core :: Audio/Video: Playback, defect, P1)

Unspecified
Android
defect

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: jhlin, Assigned: jhlin)

References

Details

Attachments

(1 file)

Follow up bug of bug 1257777, 1295106.
Priority: -- → P1
Target Milestone: --- → mozilla52
Assignee: nobody → jolin
Status: NEW → ASSIGNED
Comment on attachment 8803290 [details]
Bug 1311960 - Turn on remote media decoding preference on Android Nightly.

https://reviewboard.mozilla.org/r/87600/#review87070

Looks good, but please make sure you add the ifdef.

::: mobile/android/app/mobile.js:622
(Diff revision 1)
>  
>  // Enable the MediaCodec PlatformDecoderModule by default.
>  pref("media.android-media-codec.enabled", true);
>  pref("media.android-media-codec.preferred", true);
>  // Run decoder in seperate process.
> -pref("media.android-remote-codec.enabled", false);
> +pref("media.android-remote-codec.enabled", true);

Guard this with '#ifdef NIGHTLY_BUILD' for now. We can make a separate decision for riding the trains later on.
Attachment #8803290 - Flags: review?(snorp) → review+
Pushed by jolin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/baf3f0f96116
Turn on remote media decoding preference on Android Nightly. r=snorp
Of the 11 failed jobs on Android on your try push, 10 of them were caused by this patch.

Backed out in https://hg.mozilla.org/integration/autoland/rev/ddb157d399d04145a11031b2af29e1a697d71c4c
Failed tests passed on my devices and failed on emulators. Will investigate if there are timing issues.
Two test cases failed when pref is on:
dom/ipc/tests/test_temporaryfile_stream.html -- it happens because MediaRecorder produces zero-duration video frames on emulator. Bug 1313993 was filed to address it.
dom/media/test/crashtests/video-replay-after-audio-end.html -- remote decoder failed to dequeue buffers so the test timed out. Bug 1313991 was filed for this.
Depends on: 1313991, 1313993
Depends on: 1317887
Depends on: 1299068
Pushed by jolin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b1ff94b31819
turn on remote media decoding preference on Fennec Nightly. r=snorp
https://hg.mozilla.org/mozilla-central/rev/b1ff94b31819
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: mozilla52 → mozilla53
You need to log in before you can comment on or make changes to this bug.