wrong form POSTing with multiple forms in page

VERIFIED DUPLICATE of bug 128521

Status

()

--
major
VERIFIED DUPLICATE of bug 128521
17 years ago
17 years ago

People

(Reporter: erik, Assigned: alexsavulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla 0.9.8 seems to be unable to handle multiple forms in a single HTML page.
I've got a perl script generating a page with a bunch of forms like this:

<form method=post action="foo.pl">
<input name=button value="change" type=submit>
<input name=button value="remove" type=submit>
<input type=hidden name="foo_id" value="$some_id">
<input type=hidden name="sequence_nr" value="$some_seq_nr">
</form>

Mozilla always submits the same foo_id value for every change or submit button I
press. Netscape 4.77, with which I tested the HTML a while back, does handle it.
(Assignee)

Comment 1

17 years ago
reporter:

mozilla has a problem with missing </form> tags. this is a known bug. is this
the case here?
(Reporter)

Comment 2

17 years ago
No, I think... I checked the HTML, and I now notice that I put a form inside a
form. Ok, actually a table with forms inside a form. This is clearly not what I
intended, but I'm not sure if this triggers the form bug you mention. All forms
(both the "inner" and "outer") are properly closed.
(Assignee)

Comment 3

17 years ago
well is kind of the same problem, for the parser creates internaly only one
form. this is a dup. as soon as i find the original bug report i will mark it as
a dup.
(Reporter)

Comment 4

17 years ago
Ok. And just checking: mozilla does support more than one form in a HTML page?
(Assignee)

Comment 5

17 years ago
if the forms are well formed mozilla supports multiple forms 

wellformed means the forms are not allowed to be nested: 

<form ...>
...
<form ...>
...
</form>
...
</form>

and </form> tags are not allowed to be missing


<form ...>
...
<form ...>
...
</form>

Both examples are just wrong markup, however other browsers accept the second
one since it can be corrected.

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 128521 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.