Closed Bug 1311998 Opened 3 years ago Closed 3 years ago

[One-off searches] Right click on a result from Awesomebar closes the dropdown

Categories

(Firefox :: Search, defect, P2)

51 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 52
Tracking Status
firefox49 --- unaffected
firefox50 --- unaffected
firefox51 --- verified
firefox52 --- verified

People

(Reporter: cirdeiliviu, Assigned: adw)

References

Details

(Keywords: regression, Whiteboard: [fxsearch])

Attachments

(2 files)

[Affected versions]:
Aurora 51.0a2  Build ID 20161021004016
Nightly 52.0a1 Build ID 20161020030211

[Affected platforms]:
All (Windows 10, Mac 10.11, Ubuntu 16.04)
 
[Steps to reproduce]:
1. Open Firefox with a new profile.
2. Type something in the Awesomebar (e.g. moz).
3. Right click on a result from dropdown.

[Expected result]:
The dropdown should stay open as in previous versions and as in Search bar.

[Actual result]:
The dropdown with results closes.

[Regression Range]:
Pushlog: https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=46045ec8a4aa09a341b7209170089ade3c27c1a5&tochange=555caa0082c342c60830261ecba4c4068122207e

Regressed by bug 1180944.
Priority: -- → P2
Whiteboard: [fxsearch]
Is this something that we'd consider for an uplift?  In which case it would be good to do it before 51 goes to beta.
Flags: needinfo?(florian)
(In reply to Milan Sreckovic [:milan] from comment #1)
> Is this something that we'd consider for an uplift?

I think so, if the fix is straight forward.

Drew, is this regression on your radar?
Flags: needinfo?(florian) → needinfo?(adw)
Sigh, yeah. :-)
Assignee: nobody → adw
Status: NEW → ASSIGNED
Flags: needinfo?(adw)
We (I) removed urlbar-rich-result-popup's onPopupClick method.  It wasn't necessary IMO because autocomplete-base-popup's onPopupClick calls controller.handleEnter(), which does everything that onPopupClick did.  The problem is that the first thing urlbar-rich-result-popup's onPopupClick did was to return early when event.button==2, but controller.handleEnter() closes the popup.  So we lost that early return.

So this adds onPopupClick back so it can return early and bypass controller.handleEnter().
Comment on attachment 8805401 [details]
Bug 1311998 - [One-off searches] Right click on a result from Awesomebar closes the dropdown.

https://reviewboard.mozilla.org/r/89120/#review88338
Attachment #8805401 - Flags: review?(mak77) → review+
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5f5c92bae7db
[One-off searches] Right click on a result from Awesomebar closes the dropdown. r=mak
https://hg.mozilla.org/mozilla-central/rev/5f5c92bae7db
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Attached patch Aurora 51 patchSplinter Review
Approval Request Comment
[Feature/regressing bug #]: One-off searches in urlbar, bug 1180944
[User impact if declined]: Right clicks one the urlbar popup will close the popup instead of doing nothing
[Describe test coverage new/current, TreeHerder]: Manually tested
[Risks and why]: Low risk, small patch
[String/UUID change made/needed]: None
Attachment #8805874 - Flags: approval-mozilla-aurora?
The fix is verified on Nightly (Build ID 20161030030204). I tested on: 
* Windows 10
* Ubuntu 16.04
* Mac 10.11
Comment on attachment 8805874 [details] [diff] [review]
Aurora 51 patch

Fix a regression related to awesomebar. Take it in 51 aurora.
Attachment #8805874 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
The fix is also verified on Aurora 51.0a2 (Build ID 	20161102004003). Tested on the following OS-es:
*Windows 10
*Ubuntu 16.04
*Mac 10.11
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.