Closed Bug 1312068 Opened 5 years ago Closed 5 years ago

HTML anchor tags to local ID's do not work in child windows

Categories

(Firefox :: Untriaged, defect)

49 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1280584

People

(Reporter: robertmgary, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36

Steps to reproduce:

Clicked on link "Im broken" and found it did not jump to the location...

<html>
<bead>
    <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>
    <script type="application/javascript">
        function popBob() {
            newwin = window.open("", "_blank", "width=800,height=200,scrollbars=1");
            var myhtml= '<html><div><a href="#bob">im broken!</a><br/><br/><br/><br/><br/><br/><br/><br/><br/><br/><br/><br/><br/><br/><br/><br/><br/><br/><br/><br/><a id="bob"/>you made it!!</div></html>';

//            $('html').html(myhtml); If you want to replace the parent with the same code you can uncomment this out. The anchor works for parent windows..
            $(newwin.document.body).html(myhtml); //Put the HTML in the child window to show it does not work
        }
    </script>

</bead>
<body onload="popBob()">
</body>
</html>



Actual results:

The link is styled as a link but does not react when you click on it.


Expected results:

The link should take you to the tag with id "bob"
This was fixed in Beta50 by Bug 1280584
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1280584
You need to log in before you can comment on or make changes to this bug.