Exception Value: process() takes exactly 2 arguments (3 given)

RESOLVED DUPLICATE of bug 1302689

Status

Tree Management
Treeherder
RESOLVED DUPLICATE of bug 1302689
2 years ago
2 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Details

I was running Treeherder based on a98f432005948abaee6ea3aebb95abd7e2114b1e. A bunch of packages have been updated just before it.

Unfortunately, this was causing me not to be able to reach the following page:
http://local.treeherder.mozilla.org/api/project/mozilla-inbound/jobs/

The error I was getting:
http://dpaste.com/361JPY1
> Traceback:
> File "/home/vagrant/venv/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response
>   223.                 response = middleware_method(request, response)
> File "/home/vagrant/venv/local/lib/python2.7/site-packages/debug_toolbar/middleware.py" in process_response
>   129.                 panel.generate_stats(request, response)
> File "/home/vagrant/venv/local/lib/python2.7/site-packages/debug_toolbar/panels/sql/panel.py" in generate_stats
>   192.                     query['sql'] = reformat_sql(query['sql'])
> File "/home/vagrant/venv/local/lib/python2.7/site-packages/debug_toolbar/panels/sql/utils.py" in reformat_sql
>   27.     return swap_fields(''.join(stack.run(sql)))
> File "/home/vagrant/venv/local/lib/python2.7/site-packages/sqlparse/engine/__init__.py" in run
>   44.                 stream = filter_.process(self, stream)
> 
> Exception Type: TypeError at /api/project/mozilla-inbound/jobs/
> Exception Value: process() takes exactly 2 arguments (3 given)


Checking out 0aca73c39c26aee23e96d2bd37d2540f88eb2153 and provisioning again fixes the issue.

Comment 1

2 years ago
In bug 1302689 I'm landing package updates in a few separate batches, to make it easier to narrow down the culprit, should there be regressions.

I had checked the dependency changes for each package to see if there were any conflicting dependencies overall after all batches had landed, but missed that sqlparse fell into a later batch than the django-debug-toolbar, so momentarily between the two landings wasn't the version requested by it.

The next package update batch has just landed, so this is now fixed on treeherder master.

pip's behaviour here is also not overly helpful - it doesn't emit a warning at all in the case of version conflicts:
https://github.com/pypa/pip/issues/2687
https://github.com/pypa/pip/issues/3787
https://github.com/pypa/pip/issues/988

Whilst those pip issues aren't yet fixed, pip master does have a new `pip check` command which would have spotted the conflicting dependency in this case, which I intend to make part of the CI run once a new pip release is made that includes it:
https://github.com/pypa/pip/pull/3750
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1302689
You need to log in before you can comment on or make changes to this bug.