touch/mouse events never triggered for positioned elements

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: artnikpro, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

590 bytes, text/html
Details
(Reporter)

Description

a year ago
Created attachment 8803556 [details]
test.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.143 Safari/537.36

Steps to reproduce:

1) Open this fiddle https://goo.gl/HPCXnH in latest Firefox (v49.0.2) on Android
2) Touch the first box, you will see an alert message "touched red box"
3) Touch the second box, no alerts appears


Actual results:

Both boxes are positioned with "absolute", each has an event handler (touchstart) attached to it. The second box has "top" set to "110px". The bug is that when an element has some "top" value bigger than the it's own height then all it's touch and mouse events are stop firing


Expected results:

When clicked on green box the alert should appear (touchstart event should be fired)
(Reporter)

Comment 1

a year ago
Don't know why but now it suddenly working fine for me. Not only on that fiddle example but also on my website. Strange...
Thanks for your report!
I have tried to reproduce the issue on Firefox 49.0.2 using Huawei Honor (Android 5.1.1) and Lenovo A536 (Android 4.4.2), but didn’t manage to reproduce it.
Based on Comment 1 from the reporter and the fact that I, also, was unable to reproduce the problem, changing status to RESOLVED WORKS FOR ME.
If anyone can still reproduce it, feel free to reopen the issue and provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.