JS pop-up window causes "unknown error" alert but opens anyway

RESOLVED DUPLICATE of bug 131399

Status

()

--
major
RESOLVED DUPLICATE of bug 131399
17 years ago
17 years ago

People

(Reporter: mozilla.org, Assigned: jst)

Tracking

({regression, testcase})

Trunk
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020315
BuildID:    2002031503

When I try to click on the items featured in PC Magazine's Backspace Mozilla
says "An unknown error occured while attempting to load the requested page," but
the pop-up window loads anyway when I click the OK button.  This doesn't happen
in Internet Explorer.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.pcmag.com/article/0,2997,s=1687&a=23153,00.asp
2. Click on little picture ("Click to enlarge")


Actual Results:  An alert appears saying that "An unknown error occured while
attempting to load the requested page."  The pop-up loads fine once I click OK.

Expected Results:  Just load the pop-up window.
(Reporter)

Comment 1

17 years ago
I've encountered a similar problem while using the Yahoo! Mail web interface. 
Clicking the "Check All" link (which points to a javascript command) in a mail
folder causes the check boxes next to all the messages to be checked off (as
expected) but Mozilla says that "An unknown error occured while attempting to
load the requested page."  Because the function works I would this to just check
the boxes without the error message.

Comment 2

17 years ago
Also happen using build 2002031508 on Linux.
OS -> All.
Severity: normal → major
Keywords: regression
OS: Windows 98 → All
Hardware: PC → All

Comment 3

17 years ago
Created attachment 74423 [details]
Testcase that triggers the error, simple window.open()

Updated

17 years ago
Keywords: testcase

Comment 4

17 years ago
Must be a recent regression because I'm not seeing it in 0.9.9 on win2k. I doubt
it's a DOM bug, we don't spit out that kind of error message.

Comment 5

17 years ago
There're a lot of bug reports with this, one is marked NEW.
Perhaps we should mark this one dupe of bug 131399.

Comment 6

17 years ago
Marking dupe of bug 131399.
Will add testcase to above bug.

*** This bug has been marked as a duplicate of 131399 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.