Move 'Enable persistent logs' to NetMonitor Panel

RESOLVED DUPLICATE of bug 1145669

Status

enhancement
P3
normal
RESOLVED DUPLICATE of bug 1145669
3 years ago
11 months ago

People

(Reporter: chris.carroll, Unassigned)

Tracking

(Blocks 1 bug)

51 Branch
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20161020004015

Steps to reproduce:

Attempting to log network requests across a page load, or in my case a redirect. 

[Is there somewhere other than bugzilla that you take feature requests?]


Actual results:

When the new page loads, or a redirect kicks in, all the previous network request details are lost.


Expected results:

Feature request: enable not-clearing the log when a new page loads
Reporter

Updated

3 years ago
Severity: normal → enhancement
Summary: Developer tools:NetMonitor please enable continuous logging across page load → Developer tools:NetMonitor please enable not-clearing the log across page load or redirect

Updated

3 years ago
Component: Untriaged → Developer Tools: Netmonitor

Comment 1

3 years ago
A few ideas:
"Enable persistent logs" option move to Netmonitor interface.

Use grouping or collapsing instead of automatic cleanup.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
@Chris: does the 'Enable persistent logs' options in the Options panel [1] work for you?

Honza


[1] Click the gear icon on the right side of the main DevTools Toolbox toolbar.
Flags: needinfo?(chris.carroll)
Reporter

Comment 3

3 years ago
Yes. It does. Thank you.

So my difficulty was the UI. Googling had got me to a mozilla page about running from command line. And without being told so, I would not have interpreted "Common Preferences / Enable persistant logs" to refer to the netmonitor tool.
Flags: needinfo?(chris.carroll)
Summary: Developer tools:NetMonitor please enable not-clearing the log across page load or redirect → Move 'Enable persistent logs' to NetMonitor Panel
That option also infuences the logging within the Console panel. So, this option should also be added there, then.
The question is then whether it should still control both, the console and network logging, or work independently.

Sebastian
Blocks: firebug-gaps
Keywords: dev-doc-needed
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: dev-doc-needed
Resolution: --- → DUPLICATE
Duplicate of bug: 1145669

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.