failure to publish images when publishing images in a subdirectory

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
Composer
--
major
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: michael wendell, Assigned: Kathleen Brade)

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: publish)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I think this might be related to the fix for bug 130149.

It seems to me that publishing images to a subdirectory is trying to publish the
images anonymously.  See example below.

Steps to Reproduce:
1. Restart NS and launch Composer
2. Create a simple page with two lines of text and one image
3. Click on File - Publish As
4. Fill in all the appropriate information for your FTP server
5. Make sure to check the boxes to "Include images and other files" and "Use
this subdirectory" Type the name of an image directory
6. Click Publish

Actual results:
I get the message "user anonymous unknown".  Then I check the HTML source, and
find out that the URL for the image is now listed as the full FTP url of the
image without the username and password.

Expected results:
I would expect that the image would upload, and that the URL in the HTML source
would be something to the effect of /images/image.jpg

Comment 1

16 years ago
Was the username and password you entered correct? Because if they are not,
then FTP tries to do anonymous login.
Summary: Composer appears to be trying to publish images anonymously when publishing them to a subdirectory → Composer appears to be trying to publish images anonymously when publishing them to a subdirectory
(Reporter)

Comment 2

16 years ago
Yes, infact the actual page uploads fine, just the images do not.

Comment 3

16 years ago
Handing over to brade, who works on url manipulation during publishing process.
Assignee: cmanske → brade
(Assignee)

Updated

16 years ago
Severity: normal → major
Status: NEW → ASSIGNED
Keywords: nsbeta1
OS: Windows 98 → All
Hardware: PC → All
Summary: Composer appears to be trying to publish images anonymously when publishing them to a subdirectory → failure to publish images when publishing images in a subdirectory
Whiteboard: publish
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 4

16 years ago
Created attachment 75609 [details] [diff] [review]
clone the uri before stripping username/password

Updated

16 years ago
Attachment #75609 - Flags: review+

Comment 5

16 years ago
Comment on attachment 75609 [details] [diff] [review]
clone the uri before stripping username/password

r=adamlock

Comment 6

16 years ago
Comment on attachment 75609 [details] [diff] [review]
clone the uri before stripping username/password

sr=kin@netscape.com
Attachment #75609 - Flags: superreview+

Comment 7

16 years ago
Comment on attachment 75609 [details] [diff] [review]
clone the uri before stripping username/password

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #75609 - Flags: approval+
(Assignee)

Comment 8

16 years ago
fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

16 years ago
The image is now being uploaded, but the HTML is still being changed to the 
full FTP URL without the username and password, so the images on the uploaded 
HTML file are still not viewable.  And I am still getting a "User anonymous 
unknown" message when uploading.

I filed a new bug 133803 to cover the new issue.

The images are now being uploaded, so this one is VERIFIED.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.