Spellcheck box won't move V45.4 on mac OSX 10.11.6

RESOLVED DUPLICATE of bug 237995

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 237995
a year ago
a year ago

People

(Reporter: Kadec, Unassigned)

Tracking

45 Branch
All
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.1.50 (KHTML, like Gecko) Version/10.0 Safari/602.1.50

Steps to reproduce:

After creating email, selecting 'send' brings up spell check dialog box. But the box can't be moved away from centre of email, so obscures some of email which often contains words for which correction is suggested, but can't see the word.

Tried to click and hold on window and move it, but it won't move.


Actual results:

Spellcheck dialog box stays in top centre of email


Expected results:

Spellcheck dialog box should? move to any position within email

Updated

a year ago
Component: Untriaged → Message Compose Window
Confirmed. This is because the dialogs open from the toolbox. If the dialog would be a window, it would open independent and movable.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Mac OS X
Hardware: Unspecified → All
Made a quick patch but this didn't work.

Aleth, you are the OS X secialist. Do you know how this dialog can be made independent from the toolbar?
Flags: needinfo?(aleth)

Comment 3

a year ago
Modal dialogs aren't movable in OS X, so probably removing "modal" from the opendialog call in editor/ui/composer/content/ComposerCommands.js would change this. Not sure it's a good idea though.
Flags: needinfo?(aleth)
From the Mac-only bugs in https://mzl.la/2dZNgta we have bug 237995. Is that a match?

Comment 5

a year ago
whoa, 13 years old? No screenshot, but it's possible!

(In reply to aleth [:aleth] from comment #3)
> Not sure it's a good idea though.

To clarify, if you make it non-modal, you have to check the code flow so that you don't end up with an orphaned dialog etc.

Comment 7

a year ago
(In reply to aleth [:aleth] from comment #5)
> To clarify, if you make it non-modal, you have to check the code flow so
> that you don't end up with an orphaned dialog etc.

see also https://bugzilla.mozilla.org/show_bug.cgi?id=237995#c7
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 237995
You need to log in before you can comment on or make changes to this bug.