Closed Bug 1312241 Opened 3 years ago Closed 3 years ago

Permanent e10s test failure on WinXP: browser_shutdown_parent_own_reference.js | Test timed out - since about 10/20~

Categories

(Core :: Disability Access APIs, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- affected
firefox53 --- fixed

People

(Reporter: masayuki, Assigned: yzen)

References

Details

Attachments

(1 file)

Sine a few days ago, I see this error only on WinXP:
> 10 INFO TEST-UNEXPECTED-FAIL | accessible/tests/browser/browser_shutdown_parent_own_reference.js suddenly fails permanently | Test timed out -

I just run it with latest mozilla-central in tryserver:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=2503e1c05f1764634c0efe849ef68fa703d44a7e
Summary: Permanent e10s test failure on WinXP: browser_shutdown_parent_own_reference.js permanently since about 10/20~ → Permanent e10s test failure on WinXP: browser_shutdown_parent_own_reference.js | Test timed out - since about 10/20~
I can see the same failures on Ash. Something in this push is when it broke:
https://hg.mozilla.org/projects/ash/pushloghtml?changeset=e8d40fe383a1efe7e8c215cfa195b4d84efc5c62

Almost certainly a regression from bug 1310788. That said, I don't think XP e10s+a11y is supported at the moment, so I'm not sure what if anything needs doing here.
Flags: needinfo?(aklotz)
Given that XP is moving to ESR in 52, there is discussion about whether we should even bother turning on a11y or e10s for XP. I'll have to discuss this with some people to determine our course of action.

I'm removing the "regression" keyword: a11y on e10s with XP is simply not supported right now.
Flags: needinfo?(aklotz)
Keywords: regression
Attached patch 1312241 patchSplinter Review
Since e10s will not be supported on Win XP, disable those tests for the platform.
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Attachment #8813675 - Flags: review?(surkov.alexander)
Comment on attachment 8813675 [details] [diff] [review]
1312241 patch

Review of attachment 8813675 [details] [diff] [review]:
-----------------------------------------------------------------

r=me

I would suggest to separate e10s and non-e10s tests on folders level to avoid bulky skip-if at some point

::: accessible/tests/browser/browser.ini
@@ +8,5 @@
>  [browser_shutdown_multi_acc_reference_obj.js]
>  [browser_shutdown_multi_acc_reference_doc.js]
>  [browser_shutdown_multi_reference.js]
>  [browser_shutdown_parent_own_reference.js]
> +skip-if = !e10s || (os == 'win' && os_version == '5.1') # e10s specific test for a11y start/shutdown between parent and content.

wish we had winxp keyword, can we?
Attachment #8813675 - Flags: review?(surkov.alexander) → review+
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2c1498414a0b
do not run shutdown e10s specific tests on WinXP. r=surkov
https://hg.mozilla.org/mozilla-central/rev/2c1498414a0b
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
As windows xp is going to be maintained in the esr52 branch, doesn't we want to uplift that? THanks
Flags: needinfo?(yzenevich)
(In reply to Sylvestre Ledru [:sylvestre] from comment #8)
> As windows xp is going to be maintained in the esr52 branch, doesn't we want
> to uplift that? THanks

There's no option in bugzilla yet to request uplift to esr52, only esr45
Flags: needinfo?(yzenevich)
You need to log in before you can comment on or make changes to this bug.