Crash in about:support layers aceleration and WebGl enabled

UNCONFIRMED
Unassigned

Status

()

Core
Canvas: WebGL
P3
normal
UNCONFIRMED
2 years ago
2 years ago

People

(Reporter: Juan Mauro, Unassigned)

Tracking

(Depends on: 1 bug, {crash})

52 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted, crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-e58b356a-705c-44da-a6cc-a67a12161023.
=============================================================

Comment 1

2 years ago
Do you have some steps to reproduce the crash?
Severity: normal → critical
Flags: needinfo?(jmfjmf880)
Keywords: crash
(Reporter)

Comment 2

2 years ago
(In reply to Loic from comment #1)
> Do you have some steps to reproduce the crash?
Hi, sorry i think it is related to flash or NPAPI, here the steps i followed from a new profile:

1-Open a site with heavy flash content (i used http://www.taringa.net/shouts scrolling down to load lot of flash content)
2-Open or refresh about:support tab

Results: instant crash

Expected: No crash

terminal after crash shows: 

[4790] ###!!! ABORT: X_GLXDestroyContext: GLXBadContext; 3 requests ago: file /builds/slave/m-cen-l64-ntly-000000000000000/build/src/toolkit/xre/nsX11ErrorHandler.cpp, line 147
[4790] ###!!! ABORT: X_GLXDestroyContext: GLXBadContext; 3 requests ago: file /builds/slave/m-cen-l64-ntly-000000000000000/build/src/toolkit/xre/nsX11ErrorHandler.cpp, line 147
ExceptionHandler::GenerateDump cloned child 5441
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
[NPAPI 4891] ###!!! ABORT: Aborting on channel error.: file /builds/slave/m-cen-l64-ntly-000000000000000/build/src/ipc/glue/MessageChannel.cpp, line 2066
[NPAPI 4891] ###!!! ABORT: Aborting on channel error.: file /builds/slave/m-cen-l64-ntly-000000000000000/build/src/ipc/glue/MessageChannel.cpp, line 2066
Failed to open curl lib from binary, use libcurl.so instead

This doesn't happen when either, i disable flash with webgl enabled or, i enable flash with webgl disabled (webgl.disabled:true), but i leave layers acceleration enabled on both cases.

I'm using linux Debian stable
(Reporter)

Updated

2 years ago
Flags: needinfo?(jmfjmf880)
Downgrading this given that it is not a common usecase.

We should be able to get a better backtrace by disabling async x. :karlt?
Severity: critical → normal
Flags: needinfo?(karlt)
Priority: -- → P3
Whiteboard: gfx-noted
Could try MOZ_X_SYNC=1 in the environment, but looks like the stack walking is failing to get through Xlib and MOZ_X_SYNC may not change that.
I don't know why the scan did not find further frames.
Depends on: 1280469
Flags: needinfo?(karlt)
You need to log in before you can comment on or make changes to this bug.