Command-comma does not bring up the preferences pane

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: lth, Unassigned)

Tracking

50 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
50.0b9 (just downloaded, Sunday morning Oct 23).

Command-comma does not open the preferences panel.  Selecting the preferences panel from the menu does open it.
I assume command-comma is a common shortcut for preferences on Mac? Has this previously worked in Firefox?
Flags: needinfo?(lhansen)
(Reporter)

Comment 2

2 years ago
(In reply to Dão Gottwald [:dao] from comment #1)
> I assume command-comma is a common shortcut for preferences on Mac? Has this
> previously worked in Firefox?

Yes and yes.

On Mac, in the application menu, there is a choice for preferences, and the hotkey is command-comma.  This is standard.

It currently works in Developer Edition.  I expect it has previously worked on Mac in general, because I use it frequently, and was surprised when it did not work.  Very likely a regression.
Flags: needinfo?(lhansen)
(Reporter)

Comment 3

2 years ago
FWIW, Not fixed in Beta 10.

Comment 4

2 years ago
This works for me with 50.0b11 on Mac OS X 10.11.6. I launched Firefox and pressed Cmd+, and Preferences opened.

Lars, do you have any extensions installed? Does starting Firefox in safe mode helps?

Comment 5

2 years ago
Btw, is there a Preferences menuitem in the Firefox menu and (if it is) can you open Preferences by selecting it?

Comment 6

2 years ago
(In reply to Stefan [:stefanh] from comment #5)
> Btw, is there a Preferences menuitem in the Firefox menu and (if it is) can
> you open Preferences by selecting it?

Oops, sorry - reading comment #0 I guess there is one and it works...
(Reporter)

Comment 7

2 years ago
Still does not work for me in beta 11, Mac OS X 10.11.6.

I have some extensions installed:

- adb helper
- adblock plus
- duplicate tab
- firefox os 2.0 simulator
- link sidebar
- tab groups

Restarting in safe mode does indeed make it work.

Worse than that: after restarting in safe mode and then returning to normal mode, the problem is gone, so I can't diagnose further.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.