error/warning messages are missing from the console log with the new front-end

RESOLVED DUPLICATE of bug 1307942

Status

RESOLVED DUPLICATE of bug 1307942
2 years ago
4 months ago

People

(Reporter: jfkthame, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
For example, open the Web Console, and then load https://bugzilla.mozilla.org/.

With devtools.webconsole.new-frontend-enabled = false, I see a bunch of CSS errors reported in the log, starting with lots of occurrences of:

  Expected ‘none’, URL, or filter function but found ‘Alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.

etc.

However, with devtools.webconsole.new-frontend-enabled = true, which is now the default on Nightly, none of these messages appear. The console lists the GET requests as they're made, but none of the expected errors/warnings show up.

This means that since bug 1304178, which preffed-on the new console front-end, Nightly has become un-useful for diagnosing site problems.
Thanks for filing this. It is a duplicate of Bug 1307942, which is a blocker for turning on the new console in Developer Edition.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1307942
(Reporter)

Comment 2

2 years ago
Ah, thanks - I didn't find that one.

TBH, I think this (along with other perhaps-related issues like https://bugzilla.mozilla.org/show_bug.cgi?id=1304178#c44) is bad enough for {gecko,firefox,web} developers that we should consider reverting that pref on Nightly until it's fixed.
We will keep it under consideration and weigh the pros and cons.

Unfortunately, we don't have good telemetry data for how many users use this feature. This is the first user feedback we've received since turning it on about someone missing this feature. We do know that other browsers such as Chrome have removed this feature (or possibly made it less visible), though we don't plan to do that.

The new console does also fix longstanding issues in features that all browsers support. For example, it fixes problems with message ordering and messages being falsely identified as repeats, and fixes our support for standard features such as console.group().

We haven't had very many issues raised yet, but as user feedback comes in we'll continue to weigh the things it fixes against the bugs it introduces.

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.