worldnet.fr - clicking on OK button does not validate the input form

RESOLVED WONTFIX

Status

Tech Evangelism Graveyard
French
P2
normal
RESOLVED WONTFIX
17 years ago
3 years ago

People

(Reporter: Tristan Nitot, Unassigned)

Tracking

Details

(Whiteboard: [havecontact], URL)

(Reporter)

Description

17 years ago
1 - visit http://www.worldnet.fr/html/menu-gauche.php
2 - type a word in the text field
3 - hit Ok with the mouse
4 - nothing happens. (well, it should, as it does in IE5)
(Reporter)

Comment 1

17 years ago
This issue also happens in http://www.worldnet.fr/html/menu-gauche.php

Comment 2

17 years ago
The site uses IE-only way of accessing an element with a name="" attribute:
javascript:myform.submit();

that should be changed to the cross browser, standard, DOM 0 way:
javascript:document.forms["myform"].submit()
(Reporter)

Comment 3

17 years ago
in comment #2, I meant it also happens here:
http://www.worldnet.fr/worldnet/services/hotels/accueil.php

(I guess I still need to practice Cut&Paste ;-)

Letter sent to webmaster@worldnet.net
See also bugscape 8499.
Accepting bug. Setting P2.
Status: NEW → ASSIGNED
Priority: -- → P2
Bad browser sniffing :

		// var message="Fonction indisponible.";

		function click(e) {
			if (document.all) {
				if (event.button == 2) {
					alert(message);
					return false;
				}
			}
			if (document.layers) {
				if (e.which == 3) {
					alert(message);
					return false;
				}
			}
		}

		// if (document.layers) {
		//	document.captureEvents(Event.MOUSEDOWN);
		// }
		// document.onmousedown=click;

		if( (browserName == "Netscape" && browserVer >= 3) || (browserName ==
"Microsoft Internet Explorer" && browserVer >= 4) )
		{	version = "1";

etc.

Whiteboard: [havecontact]
Summary: worldnet.fr : clicking on OK button does not validate the input form → worldnet.fr - clicking on OK button does not validate the input form
moving.
Assignee: nitot → french
Status: ASSIGNED → NEW
Component: Europe: West → French
QA Contact: z-caillon-obsolete2 → french

Comment 6

15 years ago
Perhaps the same problem, with validate a game frame at "koodpo.com" ?
* after filling the grid, normally, go to the bottom of the frame. After click
on a banner, reload to the "clicked site", doesn't work an don't validate the game.

http://www.koodpo.com

Comment 7

15 years ago
Not a Bug:" Perhaps the same problem, with validate a game frame at "koodpo.com" ? "

* Sorry I've made a mistake. I'd no bug.
it was only, a secutity level in cookies.

Comment 8

15 years ago
Page does not exist anymore. WorldNET is dead (snif, was my ISP in 95):
http://www.internic.net/registrars/registrar-74.html
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.