Closed Bug 1312285 Opened 3 years ago Closed 3 years ago

URL Dropdown won't close on 2nd click of down arrow and fills full width

Categories

(Firefox :: Address Bar, defect)

49 Branch
x86_64
Windows 8.1
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1148716

People

(Reporter: educmale, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

1 Touch down arrow on URL bar
2 List appears, but instead of mimicking the width of the URL bar occupies the full Fox window width.  This is a recent version change
3 Touching the down arrow, again re-instates the drop-down list [up folds up, and then down, again].   Tapping the arrow a second time used to make the list fold up and away.  [Toggle].   Now, to make it disappear, one has to move the mouse off [to some other non-functioning area] and click.   Only, then, will the URL drop-down disappear



Expected results:

Expected....:  Prior [useful behavior]
a.   width of drop-down is the width of the URL box
b.   2nd touch retracts the drop-down
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64
Component: Untriaged → Location Bar
Summary: URL Dropdown won't recede on 2nd touch of down arrow and fills full width → URL Dropdown won't close on 2nd click of down arrow and fills full width
Hi John,

Can you please download the Firefox Nightly from here: https://nightly.mozilla.org/ and see if you can reproduce the part where 2nd touch retracts the drop-down? Also the width of drop-down is the width of the URL box in Nighlty.
The full width part is by design and expected.  The part about not going away when you click the arrow a second time sounds just like bug 1303771.  I can't reproduce that problem, so it would be useful to find out what you and the reporter in that bug have in common.

In addition to what ovidiu asked, could you please try reproducing in safe mode with add-ons disabled and also in a new profile?

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(educmale)
Probably a dupe, but I'll use see-also until we know more.
See Also: → 1303771
See Also: 1303771
Fixed in 52.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(educmale)
Resolution: --- → DUPLICATE
Duplicate of bug: 1148716
You need to log in before you can comment on or make changes to this bug.