Potential defect in one or more memory reporters

RESOLVED DUPLICATE of bug 1311039

Status

()

Toolkit
about:memory
RESOLVED DUPLICATE of bug 1311039
a year ago
a year ago

People

(Reporter: rahiparikh, Unassigned)

Tracking

(Blocks: 1 bug)

49 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8803739 [details]
about:memory screenshot.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

Start firefox, open about:memory page and try to run 'Measure' in 'Memory reports' section.




Actual results:

I am getting the following error message::

WARNING: the following values are negative or unreasonably large.

    explicit/js-non-window
    explicit/(16 tiny)
    explicit/(16 tiny)/heap-unclassified 

This indicates a defect in one or more memory reporters. The invalid values are highlighted.
(Reporter)

Updated

a year ago
OS: Unspecified → Mac OS X

Comment 1

a year ago
When it happens, could you save and attach the memory log from about:memory, please.
Blocks: 1311526
Flags: needinfo?(rahiparikh)
Whiteboard: [MemShrink]
(Reporter)

Comment 2

a year ago
Created attachment 8804109 [details]
about:memory report

See attached log files. 

PS: Not sure if it is related but the Firefox is miserably slow even after GC, CC, and Reduce Memory usage functions.
Flags: needinfo?(rahiparikh)
This has the potential to be more than a issue in the memory reporters, but lets start with the about:memory component.
Component: Untriaged → about:memory
Product: Firefox → Toolkit
This is the same as bug 1311039 -- "heap-allocated" is (strangely) zero, and all the other problems follow from that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1311039
You need to log in before you can comment on or make changes to this bug.