Cookies not read when redirect within frameset.

RESOLVED DUPLICATE of bug 134203

Status

()

Core
Networking: Cookies
RESOLVED DUPLICATE of bug 134203
16 years ago
16 years ago

People

(Reporter: Michiel van Leeuwen (email: mvl+moz@), Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020315
BuildID:    2002031508

on the above url,after folliwing the link to set a cookie, the first 3 methods
to read a cookie all work (direct, redirect, frameset). The last link (frameset
with a redirect in the frame) doesn't read the cookie. Al this only when only
accepting cookies from the originating web server. When accept all cookies is
set, everything works.

Reproducible: Always
Steps to Reproduce:
1. Go to the URL
2. Visit the link to set a cookie (it just sets a number)
3. visit the other links

Actual Results:  The last link doesn't print the cookie

Expected Results:  cookie: <some number> printed, just like the other links.

The source of all the php scripts is avaliable as <filename>.txt

This occured between 2002030206 and 2002030223 so I think this is a regression
from bug 87388
(Reporter)

Comment 1

16 years ago
This seems to be fixed now. I think this was bug 134203.

*** This bug has been marked as a duplicate of 134203 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.