Archive Capabilities for Closed Bugs/Product/Component

RESOLVED WONTFIX

Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED WONTFIX
19 years ago
8 years ago

People

(Reporter: dflanagan, Unassigned)

Tracking

Details

(Reporter)

Description

19 years ago
[Help Wanted] It would be very useful to have an easy way to extract all bugs for
a specific product, archive them in a portable format, optionally remove all of
the bugs but leave the product open for new submittals or optionally also remove
the Product entirely from Bugzilla.

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 1

18 years ago
Nothing I'm likely to do, not anytime soon, but I'll ACCEPT it for now.

Comment 2

18 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
Status: ASSIGNED → NEW

Comment 3

18 years ago
i think the new xml transfer stuff that endico did fixes this.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 4

18 years ago
I would call the xml transfer stuff, a start, but not exactly a fix.
The XML code still doesn't  handle attachments properly. I still
need to figure out what to do with binary attachments.
In search of accurate queries....  (sorry for the spam)
Target Milestone: --- → Bugzilla 2.12
Reopening and clearing milestone. The XML-based stuff doesn't fix this bug yet.

Gerv
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Bugzilla 2.12 → ---
What does this mean exactly?

How do we handle relations like dependencies and duplicates?  Are they saved on
the old bugs?  Are they removed from remaining bugs?

Can we restore the old data into the database?  If not, how do we search on
them?

Status: REOPENED → NEW
QA Contact: matty
Target Milestone: --- → Future
Severity: normal → enhancement
Summary: Archive Capabilities for Closed Bugs or Closed Product → Archive Capabilities for Closed Bugs/Product/Component
*** Bug 96602 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
As far as duplicates and dependencies go, couldn't you have an archive table 
that contains a list of all the archived bugs (but without all the history, 
comments, attachments etc.) so that if you click on one of the bugs that 
contains a link to an archived one, it can report back that it is archived. 
Maybe it doesn't need a new table, but some such solution.
-> Bugzilla product, trying General component, reassigning.
Assignee: tara → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
Reassigning all of my "future" targetted bugs to indicate that I'm not presently
working on them, and someone else could feel free to work on them. (sorry for
the spam if you got this twice, it didn't take right the first time)
Assignee: justdave → nobody

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: Future → ---
Assignee: nobody → general
Priority: P3 → --

Comment 12

8 years ago
(In reply to comment #0)
> [Help Wanted] It would be very useful

Very useful how? If you want to export bugs, you can already do that. If you want to have some old bugs out of your view, then you can restrict the whole product to some group nobody belongs to. But for reasons mentioned in comment 7, we cannot break referential integrity. If you want to export bugs then delete the product or some components, you can already do that too.
Status: NEW → RESOLVED
Last Resolved: 18 years ago8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.