Crash when switching to bookmarks tab in sidebar [nsXULOutlinerBuilder::GetTemplateActionCellFor]

RESOLVED WORKSFORME

Status

()

Core
XUL
--
critical
RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: Aleksey Nogin, Unassigned)

Tracking

({crash, regression})

Trunk
x86
All
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs retesting in seamonkey])

(Reporter)

Description

16 years ago
I had Mozilla crash in nsXULOutlinerBuilder::GetTemplateActionCellFor (once, so
filing as UNCONFIRMED) when I tried to switch the sidebar from "Search" to
"Bookmarks".

Gdb says:

(gdb) bt
#0  0x40df2353 in nsXULOutlinerBuilder::GetTemplateActionCellFor ()
   from /usr/lib/mozilla/components/libgkcontent.so
#1  0x40deff89 in nsXULOutlinerBuilder::GetCellProperties () from
/usr/lib/mozilla/components/libgkcontent.so
#2  0x41a366ed in nsOutlinerBodyFrame::PaintCell () from
/usr/lib/mozilla/components/libgklayout.so
#3  0x41a365e6 in nsOutlinerBodyFrame::PaintRow () from
/usr/lib/mozilla/components/libgklayout.so
#4  0x41a35b54 in nsOutlinerBodyFrame::Paint () from
/usr/lib/mozilla/components/libgklayout.so
#5  0x41933606 in PresShell::Paint () from
/usr/lib/mozilla/components/libgklayout.so
#6  0x41ab8e6d in nsView::Paint () from /usr/lib/mozilla/components/libgkview.so
#7  0x41ac15c8 in nsViewManager::RenderDisplayListElement () from
/usr/lib/mozilla/components/libgkview.so
#8  0x41ac1433 in nsViewManager::RenderViews () from
/usr/lib/mozilla/components/libgkview.so
#9  0x41ac037e in nsViewManager::Refresh () from
/usr/lib/mozilla/components/libgkview.so
#10 0x41ac284b in nsViewManager::DispatchEvent () from
/usr/lib/mozilla/components/libgkview.so
#11 0x41ab89f1 in HandleEvent () from /usr/lib/mozilla/components/libgkview.so
#12 0x411a71d2 in nsWidget::DispatchEvent () from
/usr/lib/mozilla/components/libwidget_gtk.so
#13 0x411a70f2 in nsWidget::DispatchWindowEvent () from
/usr/lib/mozilla/components/libwidget_gtk.so
#14 0x411aa224 in nsWindow::DoPaint () from
/usr/lib/mozilla/components/libwidget_gtk.so
#15 0x411aa335 in nsWindow::Update () from
/usr/lib/mozilla/components/libwidget_gtk.so
#16 0x411aa49d in nsWindow::Update () from
/usr/lib/mozilla/components/libwidget_gtk.so
#17 0x411aa0ba in nsWindow::UpdateIdle () from
/usr/lib/mozilla/components/libwidget_gtk.so
#18 0x4039d79d in g_idle_dispatch () from /usr/lib/libglib-1.2.so.0
#19 0x4039c773 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#20 0x4039cd39 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#21 0x4039ceec in g_main_run () from /usr/lib/libglib-1.2.so.0
#22 0x402b7333 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#23 0x4119aae6 in nsAppShell::Run () from
/usr/lib/mozilla/components/libwidget_gtk.so
#24 0x4117a9de in nsAppShellService::Run () from
/usr/lib/mozilla/components/libnsappshell.so
#25 0x08051e61 in DoCommandLines ()
#26 0x080527ab in main ()
#27 0x404fa627 in __libc_start_main (main=0x8052660 <main>, argc=1,
ubp_av=0xbfffe964,
    init=0x804c9fc <_init>, fini=0x8053e1c <_fini>, rtld_fini=0x4000dcc4
<_dl_fini>, stack_end=0xbfffe95c)
    at ../sysdeps/generic/libc-start.c:129

This is BuildID 2002031319 on RedHat Linux 7.2 (+ all updates).
(Reporter)

Updated

16 years ago
Keywords: crash
(Reporter)

Comment 1

16 years ago
Managed to reproduce, seems 100% reproducible.

To reproduce:
0) Make sure sidebar has both "search" and "bookmarks" tabs and "bookmarks" is
active.
1) To to Bugzilla query page and query for something.
-> Bugzilla displays the bug list and sidebar automagically switches to the
search tab
2) Click on the bookmarks tab in sidebar.

Expected: you get bookmarks tab displayed.
Actual: crash :-(

This is a very recent regression - could this be caused by the recent check-in
to nsXULOutlinerBuilder.cpp:

revision 1.45
date: 2002/03/12 22:45:05;  author: ben%netscape.com;  state: Exp;  lines: +73 -58
Fix for 128815 - numerous bookmarks improvements, including fixes for bugs:
77411, 114142, 126748, 128571.
- update outliner builder to expose "Sort" method publicly.
r=blake, sr=hyatt, a=asa




Severity: major → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: Crash in nsXULOutlinerBuilder::GetTemplateActionCellFor → Crash when switching to bookmarks tab in sidebar [nsXULOutlinerBuilder::GetTemplateActionCellFor]
(Reporter)

Comment 2

16 years ago
P.S. Sorry, no talkback due to bug 86068

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 131203 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
v
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

16 years ago
Are you sure it's a dup? Notice that bug 131203 seems to imply a crash in JS,
while this one crashes in nsXULOutlinerBuilder::GetTemplateActionCellFor.
(Reporter)

Comment 6

16 years ago
I believe that this bug is in fact a duplicate of bug 127842.

Comment 7

16 years ago
*** Bug 146023 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
the stacks for this and the bug this is duped against don't match.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 9

16 years ago
Duplicated bug 146023 was for W2K too - OS: Linux -> All
OS: Linux → All
Aleksey in comment #1
> Managed to reproduce, *seems 100% reproducible.*
> 
> To reproduce:
> 0) Make sure sidebar has both "search" and "bookmarks" tabs and "bookmarks" is
> active.
> 1) To to Bugzilla query page and query for something.
> -> Bugzilla displays the bug list and sidebar automagically switches to the
> search tab
> 2) Click on the bookmarks tab in sidebar.

(In reply to comment #6)
> I believe that this bug is in fact a duplicate of bug 127842.

Aleksey, can you still reproduce this?
bug 127842 has been fixed.

Assignee: hyatt → nobody
Status: REOPENED → NEW
QA Contact: shrir → xptoolkit.xul
(Reporter)

Comment 11

11 years ago
I do not have anything remotely recent around, and 1.8a5 (BuildID 2004111118) still crashes:

0) Make sure sidebar has both "search" and "bookmarks" tabs and "bookmarks" is
active.
1) To to Bugzilla query page and query for something.
2) Click on the "search" tab in sidebar.

The build is non-debug, so no back trace, but it's still in libgklayout.so

Andrew, Seems to me this must be gone - can you recreate this? I don't use sidebar and cant get both search and bookmarks active at same time in sidebar to properly test it (perhaps because I have xsidebar installed?)  
Reporter or anyone else still seeing this issue?

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets

Updated

8 years ago
Whiteboard: [needs retesting in seamonkey]

Comment 14

6 years ago
No instance of this signature for any Product or Version in the last 4 weeks. Closing as Works For Me.
Status: NEW → RESOLVED
Last Resolved: 16 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.