Geolocation.getCurrentPosition with timeout fires error after success

RESOLVED DUPLICATE of bug 1283563

Status

()

RESOLVED DUPLICATE of bug 1283563
2 years ago
2 years ago

People

(Reporter: teksalx, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

https://bilgiprog.github.io/jsders/test/geotest.html


Actual results:

I allow to share my location, then it prints "Success. Lat: xxx, Lon: XXX" and after timeout(4 sec.s in this test) it displays "Error. Timeout."


Expected results:

It should not have triggered error after success. "Error. Timeout." should not appear.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1283563
You need to log in before you can comment on or make changes to this bug.