Add DAMP stress test for Reps

RESOLVED DUPLICATE of bug 1358180

Status

--
enhancement
RESOLVED DUPLICATE of bug 1358180
2 years ago
4 months ago

People

(Reporter: linclark, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Currently mounting reps is slow. I'm not sure how much we can do to affect this, but if we add a test we can at least see what we can do.
(Reporter)

Comment 1

2 years ago
Created attachment 8804259 [details] [diff] [review]
Bug1312737.patch

This test outputs a single console message with 1000 numbers.

On my machine, I get these numbers.

Old console: 105ms
New console w/ reps: 709ms

I'll give it a try with the new console, but not using reps, to see whether new console itself is causing any of that.
(Reporter)

Comment 2

2 years ago
On my machine, new console without reps is 301, so we definitely have some optimization to do in Reps.
(Reporter)

Comment 3

2 years ago
Created attachment 8804263 [details] [diff] [review]
testing-without-reps.patch

In case you want to run the tests yourself, here's the console without reps code, plus some temporary DAMP changes.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358180

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.