[pogo.com] Application crashes when closing a window that contains an applet

RESOLVED DUPLICATE of bug 169547

Status

Core Graveyard
Java: OJI
P2
critical
RESOLVED DUPLICATE of bug 169547
16 years ago
7 years ago

People

(Reporter: Don Harris, Assigned: Peter Lubczynski)

Tracking

({crash, qawanted, topembed+})

Trunk
mozilla1.3beta
PowerPC
Mac OS X
crash, qawanted, topembed+

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:NA], URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9) Gecko/20020310
BuildID:    0.9.9

surf to pogo.com...select euchre...enter lounge...enter table...play a few games
...the browser will crash and disappear....also while in the lounge with the 50
euchre tables...try to drad the window drag button to view the other online
users...dragging the button drags an opaque windo with it.

Reproducible: Always
Steps to Reproduce:
1.add MRJplugin d8
2.
3.

Actual Results:  100% everytime

Expected Results:  don't know  make java with the MRJplugin d8  more reliable in
OSX1.3 and apple java update 1.3.1
-> Oji
Assignee: idk → joe.chou
Component: Java-Implemented Plugins → OJI
QA Contact: avm → pmac

Updated

16 years ago
Keywords: crash
Summary: browser crashes and disappears & window problems → browser crashes and disappears & window problems

Comment 2

16 years ago
Mac...

Follow up email to beard... indicates that this is not fixed with more recent
plug-in versions either.

I'm using MRJpluginCarbon 1.0b2 ... anyway I can use the plugin to play euchre
on www.pogo.com  but the browser will crash after say 4 or 5 games or if the
intermission wait comes on after the game or say changing lounges multiple times
and multiple is only 2 or 3 times. It does work but for not enough length of time...

Don, is there any chance that you can supply a crash reporter log? It is
possible that this may be related to something like as bug 136063.
Assignee: joe.chou → bnesse

Comment 3

16 years ago
Granted, I haven't tried playing the games, only observed, but with the patch
from bug #136063, I'm not crashing.

Comment 4

16 years ago
I played a few random games without any trouble using the 1.0fc1 release. Don,
please grab the latest plug-in and report back.

http://homepage.mac.com/pcbeard/MRJPlugin/
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 5

16 years ago
in http://bugscape.netscape.com/show_bug.cgi?id=12941 beppe wrote the text
below. I marked said bugscape bug as a dupe of this bugzilla bug. Brian, if you
disagree, please set me straight; thanks!

beppe wrote:
I did get a crash, and I did get a talkback report:

ID:6086046

Stack Trace
AWT.DLL + 0x1af76 (0x6d01af76)
0xf000e7d0 
Keywords: topembed+

Comment 6

16 years ago
Adding qawanted. The guy posted a TB ID three months ago. Someone who can, please retrieve 
it.
Keywords: qawanted

Comment 7

16 years ago
I can reproduce a crash when closing a window that contains the applet. Here are
the following steps:

1) Go to pogo.com
2) Click on Euchre link
3) Click on a room name
4) After applet is completely loaded, click on "Watch" button to view a on-going
game
5) An additional window should open and loading this applet
6) Now, close this window (command -W)
7) Application should hang with Java Plugin error

Comment 8

16 years ago
Created attachment 103088 [details]
Java console information

Comment 9

16 years ago
I can reproduce comment 7 on both the branch (2002-10-14-05) and trunk
(2002-10-16-08) OS X builds. Tested under 10.2.1.

Comment 10

16 years ago
bnesse gone, --->peterl
Assignee: bnesse → peterl
Status: ASSIGNED → NEW

Comment 11

16 years ago
Peter: do you need a reduced test case or anything?
Priority: -- → P2
Whiteboard: [PL2:NA]
Target Milestone: --- → mozilla1.3beta

Comment 12

16 years ago
I thought this might be a OS X  only issue but I can reproduce this crash (using
the steps in comment 7) on my Windows ME computer. Tested with 2002-10-09-08 trunk. 

Updated

16 years ago
QA Contact: pmac → petersen

Comment 13

16 years ago
is this a dup of another bug? do we have other java problems on pogo.com? can
someone verify this happens on Win32 and UNIX too?

Comment 14

16 years ago
With the patch in bug 136927, I'm not crashing in a debug build.
Summary: browser crashes and disappears & window problems → [pogo.com] browser crashes and disappears & window problems

Comment 15

15 years ago
I think the bug has morohed since originally discovered. I only see this failure
with OSX 10.2... prior OS with N7 virtually stable in this area

Comment 16

15 years ago
Based on the original steps provided by the reporter, I can't reproduce the
problem. Playing the Euchre game is stable and doesn't crash after numerous
games have been completed. In addition, I don't see the dragging issue also
mentioned by the reporter. I can drag the scroll bar freely when viewing the
tables in the lounge.

However, Comment 7 is still occuring on the OSX 2002-12-06-08 Trunk build. This
might have been the crash the reporter had seen but didn't mention specify
details. The crash occurs when closing the window (via the window's close box)
that's showing the game in action. The game play window is opened when clicking
on the Play or Watch button that appears in the lounge.


Note: When you open the game play window, you should see a small x button in the
bottom left corner of window. If a user click this button, the applet will exit
gracefully. However if you close the window mentioned above, then the applet
crashes.


Last time, I checked this issue. I could reproduce under Windows ME  using a
trunk build. Both my OS X machine and Windows machine had 1.3.1_01 JRE
installed. Since my Windows OS has been updated to Win XP Professional, I'm not
sure what JRE will be on it. I will pull the latest Win32 trunk build on Monday
(12/09)and try it out.

Comment 17

15 years ago
Note the fix in bug 183681. It may solve some of these issues.
Depends on: 183681

Comment 18

15 years ago
I am thinking this may be memory related. A similar crash on a windows machine
returned a lava low memory error in the java console. I raised the VM and the
failure seemed to fix.

Comment 19

15 years ago
Using the 2002-12-09-08 Windows trunk under Windows XP Pro, I can't reproduce
the crash based on Comment 7. This Windows OS has JRE 1.4.0_01 installed. My
previous Windows ME machine had a older JRE (1.3.1_01).

Comment 20

15 years ago
Based on the steps in Comment 7, this problem seems to be only occuring under
10.2.2. Using the 2002-12-09-08 OS X trunk under 10.2.2, closing the game play
will hang the application. Under 10.1.5 using this same trunk build, the window
closes and the applet exits gracefully (no crash occurs). 

Comment 21

15 years ago
Updating summary to reflect issue.
Summary: [pogo.com] browser crashes and disappears & window problems → [pogo.com] Application crashes when closing a window that contains an applet

Comment 22

15 years ago
Lowering the VM to the Windows minimum on a 128 mg ram Win2K box I am able to
repro the crash on exit. Petersen... Should I open a separate bug?

Comment 23

15 years ago
Lowering the VM to the Windows minimum on a 128 mg ram Win2K box I am able to
repro the crash on exit. Petersen... Should I open a separate bug?

Comment 24

15 years ago
 All of my crashes came when closing the window as mentioned in comment 7. So
that crash is only when you quit ? If that's the case, then a new bug should be
opened.

Comment 25

15 years ago
OK I will post a new but possibly related bug

Comment 26

15 years ago
This page has liveconnect on it and its possible thats why it's crashing on
close on the Mac. Please reopen if this still occurs after bug 169547 is fixed.

*** This bug has been marked as a duplicate of 169547 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 27

15 years ago
Why does this bug have no crash log?

Comment 28

15 years ago
Created attachment 111244 [details]
Screen shot of Java exception dialog

This dialog appears after closing the window. I can't click it's OK button
since the cursor turns into a spinning color cursor. My only way to exit the
application is to force quit.

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.