[e10s][HiDPI] SVG cursor is upscaled incorrectly on HiDPI screen

RESOLVED DUPLICATE of bug 1304098

Status

()

Core
Widget
RESOLVED DUPLICATE of bug 1304098
a year ago
a year ago

People

(Reporter: xidorn, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox52 affected)

Details

See the attachment in bug 888781 comment 13. Open the test page and try the last block.

That block uses an SVG image as cursor, so the cursor should be displayed properly in whatever DPI the screen is. However, it is upscaled incorrectly with e10s on all platforms.

It is mainly because we prerender the cursor in the content process (in PuppetWidget::SetCursor) in the image's intrinsic size, and send the surface data to the chrome process to get the cursor displayed.

Even if we use GetFrameAtSize to generate the image in scaled size, we would need a way to send the original size to the chrome process, otherwise it would just be scaled again.
Seems similar to bug 1304098
I guess it is actually a duplicate.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1304098
You need to log in before you can comment on or make changes to this bug.