No sound when playing video on particular devices

RESOLVED WORKSFORME

Status

()

Firefox for Android
Audio/Video
P1
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: u421692, Unassigned)

Tracking

({qablocker, regression})

52 Branch
qablocker, regression
Points:
---

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51 unaffected, firefox52 fixed, firefox53 fixed)

Details

(Reporter)

Description

2 years ago
Device: Nexus 6 (Android 6.0.1)
1. Go to http://people.mozilla.org/~atrain/mobile/tests/media.html
2. Play the second video

Expected result:
Video plays without any issue, with sound

Actual result:
Video plays without any issue, but with no sound

I was able to reproduce this only on Nexus 6, both on Aurora and Nightly

Regression window:
2016-10-03 - good build
2016-10-04 - bad build
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=955840bfd3c20eb24dd5a01be27bdc55c489a285&tochange=42c95d88aaaa7c2eca1d278399421d437441ac4d

I suspect bug 1306186, but this is not merged in Aurora, and Aurora it's also affected, so it might be something else.
Chunmin, 
Can you help check this bug? Would it be related to Bug 1309694?
Flags: needinfo?(cchang)
Priority: -- → P1
OK, I'll check whether this could be reproduced in Z3C first. I'll find a Nexus 6 later.
Flags: needinfo?(cchang)
Hmm...I can't reproduce it on my Z3C with android 5.1.1. I'll try it on Nexus 5 or simulator later.
Let me know if you cannot find a Nexus 6.
(Reporter)

Comment 5

2 years ago
If you need more information, logcat or anything else, I'll be happy to provide it, since we have a Nexus 6 in the office.
It cannot be reproduced on nexus 5 (Android 6.0.1) with neither.

(In reply to Mihai Pop from comment #5)
> If you need more information, logcat or anything else, I'll be happy to
> provide it, since we have a Nexus 6 in the office.
Thanks Mihai! I'll let you know if I need your help :)
Can we figure out how this affects 51?  What got uplifted compared to the range in comment 0?
status-firefox51: affected → unaffected
Flags: needinfo?(mihai.g.pop)
Version: Trunk → 52 Branch
The nexus 6 works well on the latest build. I'll trace back to see what I could find.
status-firefox53: --- → affected

Comment 9

2 years ago
I had this issue on my lg g5, but after updating the android version the issue was resolved. What version of android are you using?
(In reply to Parker from comment #9)
> I had this issue on my lg g5, but after updating the android version the
> issue was resolved. What version of android are you using?
It had a problem to play sound on Nexus 6, but it works fine now(I try it today). The more reliable tests for cubeb(the audio engine behind firefox) is currently planning[0]. I'll forward the plan for Android if we have a solution.

[0] https://github.com/kinetiknz/cubeb/issues/193
If this bug does not happen again, maybe we could close it.
Mihai, 
Can you help check it again?
Sorina, 
Can you help test if the latest nightly still has this problem?
Thanks.
Flags: needinfo?(sorina.florean)
Hi, 

Tested on latest Nightly (2017-01-08) with following devices: 
- LG G4 (Android 5.1)
- HTC Desire 820 and Nexus 5 (Android 6.0.1)
- Nexus 9 (Android 7.0)
The second video from page http://people.mozilla.org/~atrain/mobile/tests/media.html is playing without issues, with sound. I don't have the Nexus 6 device with (Android 6.0.1).
Flags: needinfo?(sorina.florean)
Flags: needinfo?(u421692)
During triage I said I would test this with a Nexus 6 (although I am running on Android 7.0 rather than 6.0.1).

Using both the latest Aurora and Nightly I was unable to reproduce the issue with the second video (H264/MP4) playing without sound.
Closing this out as WFM then. If anybody is still able to reproduce, feel free to reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox52: affected → fixed
status-firefox53: affected → fixed
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.