Gmail compose textbox scrolls unnecessarily after paste

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
2 years ago
3 months ago

People

(Reporter: botond, Unassigned)

Tracking

({top50})

unspecified
top50
Points:
---

Firefox Tracking Flags

(platform-rel +)

Details

(Whiteboard: [gfx-noted][platform-rel-Google][platform-rel-Gmail])

STR:
  1. Compose an email in Gmail. Make it long enough to scroll.
  2. Cut a piece of text from the email body.
  3. Paste it elsewhere into the email body.

Expected results:

  The email does not scroll unnecessarily. In particular, unless
  the text being pasted is so large that it doesn't fit into the
  screen, no scrolling should happen at all.

Actual results:

  The email scrolls unnecessarily, often by a large amount.

Sometimes it happens with copy & paste as well.

Not clear whether this is a site issue or a Firefox issue.
This can also happen when pasting text from an external program (or another Firefox window).
Summary: Gmail compose textbox scrolls unnecessarily after cut & paste → Gmail compose textbox scrolls unnecessarily after paste

Comment 2

2 years ago
Can you try on other browsers to confirm if this is a site issue or a Firefox one?

I tried to reproduce it on latest Nightly (Build ID 20161101030207) and when I cut and paste a row, the email didn't scroll. When I cut and paste more than this the email scrolled, but it did the same on Chrome. Not sure if I do it right. Can you provide a screencast of the issue, so we can understand it better?
Flags: needinfo?(botond)
(In reply to Liviu Cirdei [:liviucirdei] from comment #2)
> Can you try on other browsers to confirm if this is a site issue or a
> Firefox one?

In Firefox, after pasting, the composte textbox scrolls to a wrong place.

In Chrome, after pasting, the compose textbox flickers briefly, as if it were being scrolled to a wrong place and then back right away.

In IE11, there is no scrolling or flicker after pasting.

I don't have access to Edge or Safari.
(In reply to Liviu Cirdei [:liviucirdei] from comment #2)
> Can you provide a screencast of the issue, so we can understand it better?

Please see https://people-mozilla.org/~bballo/gmail-paste-jump.ogv
Flags: needinfo?(botond)

Comment 5

2 years ago
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID 20161102030205

Thanks for the info and for the screencast.
I can reproduce the issue on latest Nightly on Windows 10.
Component: Untriaged → Panning and Zooming
Product: Firefox → Core
Priority: -- → P3
platform-rel: --- → ?
Whiteboard: [gfx-noted] → [gfx-noted][platform-rel-Google][platform-rel-Gmail]
platform-rel: ? → +

Comment 6

3 months ago
Does this issue still occur?
Flags: needinfo?(botond)
Keywords: top50
I can't reproduce the issue in today's Nightly. It's not clear whether it was a Firefox change or a website change that fixed it.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(botond)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.