Linux <select> Colors are different when E10s=True and E10s=False

RESOLVED DUPLICATE of bug 1300784

Status

()

Core
Layout: Form Controls
P3
minor
RESOLVED DUPLICATE of bug 1300784
2 years ago
2 years ago

People

(Reporter: JW_SoftvisionQA, Unassigned)

Tracking

({regression})

52 Branch
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(firefox52 fix-optional)

Details

(URL)

(Reporter)

Description

2 years ago
STR: 
Run with E10s=True then with E10s=False
1. Navigate to https://people.mozilla.org/~mnoorenberghe/w3c_notifications.htm
2. Click the Direction Datalist
3. Observe the Background color

Actual:
Background colors are not the same

Expected:
Background colors are the same

Windows is not affected
Ubuntu is affected

Video showing the differences:
https://testing-1.tinytake.com/sf/MTA3NTg2NV80MzE2OTk4
(Reporter)

Updated

2 years ago
No longer blocks: 1296638
Summary: Datalist Background Color is different when E10s=True and E10s=False → <Select> Background Color is different when E10s=True and E10s=False
I think this is an intentional change that the <select> dropdown uses native styling with e10s. This is related to bug 910022 but not a dupe since this form doesn't specify any non-default styling.

Mike, do you know if we intentionally change the default styling in e10s to be more native?
Blocks: 879538
Component: Form Manager → Layout: Form Controls
Flags: needinfo?(mconley)
Keywords: regression
Product: Toolkit → Core
See Also: → bug 910022
Summary: <Select> Background Color is different when E10s=True and E10s=False → Linux <select> Colors are different when E10s=True and E10s=False
Why do we need to make this change e10s specific ? Native styling looks better and worth the change no matter e10s is on or off.
Priority: -- → P3
We're in the process of merging the e10s and non-e10s backends for the <select> dropdown, which should solve this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mconley)
Resolution: --- → DUPLICATE
Duplicate of bug: 1300784
marking fix-optional to get this off the triage list, we'll track bug 1300784 instead.
status-firefox52: affected → fix-optional
You need to log in before you can comment on or make changes to this bug.