Browser is sending cookies written for one domain to another even though the domains doesn't match

VERIFIED DUPLICATE of bug 130752

Status

()

VERIFIED DUPLICATE of bug 130752
17 years ago
17 years ago

People

(Reporter: racham, Assigned: morse)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I am filing this bug based on emails I got from one of the SNS 
(ScreenNameService) team members. Here is the complete email I have received in 
this regard. Will also add Steve Morse to the discussion thread there.

Praveen Alavilli wrote:
Cookies set on mc.aol.com are replayed back on gitammc.aol.com (note that there 
is no dot in between gitam & mc) - I just verified it again  (10th time :-))  !!

It's happens only in Netscape - IE handles it correctly !!

I don't remember reading in cookie specs that it is an expected behavior. Anyone 
know anything about it ? Is it a known issue ?

You can test it using any proxy tool - brett's or JB.

- Praveen
(Reporter)

Updated

17 years ago
Keywords: nsbeta1
(Assignee)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 130752 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.