embedded YouTube video goes full-screen only after rotating the device

RESOLVED WORKSFORME

Status

()

P5
normal
RESOLVED WORKSFORME
2 years ago
28 days ago

People

(Reporter: amir.aharoni, Unassigned)

Tracking

52 Branch
All
Android
Points:
---

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51 affected, firefox52 wontfix)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

I tested this on Nightly 52.0a1 2016-10-26 on Samsung Galaxy S7.

0. Make sure that screen rotation is enabled on your device.
1. Go to http://yms.livejournal.com/2963777.html
2. Play the first embedded YouTube video.
3. Tap the full-screen button (arrows pointing to different directions diagonally).
-> Observed: The video doesn't become full-screen.
4. Rotate the screen 90°.
-> Observed: Now the video does become 


Actual results:

The video goes full-screen only after rotating the device.


Expected results:

The video must go full-screen immediately after tapping the button.

Comment 1

2 years ago
I was able to reproduce this issue on two devices only, on a Samsung Galaxy S6 EDGE (Android 6.0.1) and on a Samsung Galaxy S7 EDGE (Android 6.0.1), and it seems that the whole page enters in full screen not just the video and in portrait you cannot exit full screen(media controls are not displayed), only in landscape.
This issue was also tried on a Samsung Galaxy Note 5 with android 6.0.1, a Huawei Honor 5x (Android 5.1.1) and HTC Desire 820 (6.0.1) and could not be reproduced.

Please note that this issue is reproducible on the latest Nightly build (2016-10-26)and latest Aurora(2016-10-26), beta 50.0b10 and Release 49.0.2 not affected
Status: UNCONFIRMED → NEW
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
status-firefox51: --- → affected
status-firefox52: --- → affected
Component: General → Audio/Video
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → All
Keywords: regressionwindow-wanted

Comment 2

2 years ago
Hi Kevin,

A correct regression window cannot be found for this bug from my side, I tried manually finding it but some weird behavior is triggered by this bug. 

Tried on 50.0a2(19-09-2016) and it couldn't be reproduced, same on 51.0a2(20.09-2016) and first bad build was 51.0a2 (21.09.2016)[Nothing in the pushlog (for the 20-21) that could have triggered this issue].
Rechecked the 19.09.2016 build, and it seems that fter reproduced once, i could hit the bug in all previous working builds, also on present beta (50.0b10) intermittently. I thought the device was the problem (Samsung Galaxy S6 EDGE Android 6.0) but after a device restart, same behavior.
Too late for firefox 52, mass-wontfix.
status-firefox52: affected → wontfix
Mihai, could you please help check if this bug still happens in nightly/59? We added a new feature in 58 that automatically rotates and locks the orientation when playing fullscreen video. Maybe it'll workaround the issue on your Galaxy EDGEs. Thanks a lot.
Flags: needinfo?(mihai.ninu)
Tested again with the affected devices on latest Nightly build: Samsung Galaxy S6 (Android 7.0) and Samsung Galaxy S7 EDGE (Android 7.0).

Following the steps and video from description, this issue is no longer reproducible on devices affected. With devices in landscape mode or portrait, the video enters full screen when the button is tapped.
Flags: needinfo?(mihai.ninu)
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: -- → P5

Comment 7

28 days ago
Hi,

Taking into consideration Comment 2, I will remove the "regression-wanted" keyword, and based on Comment 5, I will close this issue as Works for me.

Thank you!
Status: NEW → RESOLVED
Last Resolved: 28 days ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.