Closed Bug 1313363 Opened 4 years ago Closed 4 years ago

notifications on android are truncated

Categories

(Core :: DOM: Push Notifications, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox50 --- fixed
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: bkelly, Assigned: sebastian)

Details

Attachments

(4 files)

It seems the text in our push notifications is getting truncated on android.  This was raised by the Guardian Mobile Lab when they enabled their debate coverage push system to firefox:

https://twitter.com/_alastair/status/788778122770542593

The tweet shows the same message being shown fully from a chrome notification, but truncated in a firefox notification.

Since we don't truncate on other platforms, it seems this must be coming from our android integration in some way.
CC'ing various folks who might know what is going on or who to ask about it.
I think maybe we need to use the 'expandable' notifications introduced in Jelly Bean (or around there). Sebastian, do you want to find someone for this?
Flags: needinfo?(s.kaspari)
Yeah, we should just use 'BigTextStyle' and then this shouldn't be truncated on Android 4.1+ devices anymore. I'll write a patch.
Assignee: nobody → s.kaspari
Status: NEW → ASSIGNED
Flags: needinfo?(s.kaspari)
That's better.
Comment on attachment 8805558 [details]
Bug 1313363 - NotificationClient: Use BigTextStyle instead of InboxStyle.

https://reviewboard.mozilla.org/r/89326/#review88592

LGTM.
Attachment #8805558 - Flags: review?(gkruglov) → review+
Pushed by s.kaspari@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e16379c75b3d
NotificationClient: Use BigTextStyle instead of InboxStyle. r=Grisha
The change is so minor. Let's try to uplift this.
Comment on attachment 8805558 [details]
Bug 1313363 - NotificationClient: Use BigTextStyle instead of InboxStyle.

Approval Request Comment

[Feature/regressing bug #]: It looks like this isn't a regression and has always been a problem.

[User impact if declined]: We only show one line of text in web notifications (See linked screenshot in comment 0).

[Describe test coverage new/current, TreeHerder]: Local testing with test page: https://goroost.com/try-web-push

[Risks and why]: Very Low. This patch just changes the notification style. The new style can display multiple rows of text.

[String/UUID change made/needed]: -
Attachment #8805558 - Flags: approval-mozilla-beta?
Attachment #8805558 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/e16379c75b3d
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Comment on attachment 8805558 [details]
Bug 1313363 - NotificationClient: Use BigTextStyle instead of InboxStyle.

This is clearly a very visible issue (based on the twitter screen shots) for Fennec push notification users, Aurora51+, Beta50+
Attachment #8805558 - Flags: approval-mozilla-beta?
Attachment #8805558 - Flags: approval-mozilla-beta+
Attachment #8805558 - Flags: approval-mozilla-aurora?
Attachment #8805558 - Flags: approval-mozilla-aurora+
This patch doesn't apply to aurora (or beta, or the now-merged release). Did the file get moved around?

Could we get a rebased patch if this needs to get uplifted?
Flags: needinfo?(s.kaspari)
Updated patch for Aurora.
Flags: needinfo?(s.kaspari)
Updated patch for Beta.
You need to log in before you can comment on or make changes to this bug.