Add a parameter to a port.onMessage

RESOLVED DUPLICATE of bug 1299411

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1299411
10 months ago
10 months ago

People

(Reporter: andym, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
As per bug 1309926 comment 1:

> the second parameter to a port.onMessage listener is the port that received the message

I am guessing this would be the place where the second argument, portObj, is missing:

https://dxr.mozilla.org/mozilla-central/source/toolkit/components/extensions/ExtensionUtils.jsm#1225

Once this is fixed, I am quite optimistic we would have a well working 1st version of webext-based uBO.

Updated

10 months ago
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1299411
You need to log in before you can comment on or make changes to this bug.