Status

()

defect
P3
normal
VERIFIED INVALID
20 years ago
20 years ago

People

(Reporter: yugo, Assigned: troy)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Trt this.
----- BEGIN -----
<div style="border-style:ridge;">
LONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLON
GLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONGLONG
</div>
-----  END  -----
Contents overflows the border.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
That's how it's supposed to work. The default 'overflow' value is 'visible'. Set
it to 'hidden' if you want the overflow clipped
Status: RESOLVED → REOPENED
This problem is not from the CSS property overflow.
See two screenshots of this code.
http://www.felix.or.jp/~yugo/js/test/test02opera.gif
http://www.felix.or.jp/~yugo/js/test/test02mozilla.gif
Status: REOPENED → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Yes, that's the way 'overflow' and sizing of block-level elements works. Gecko
is displaying the page correctly, per CSS2. Opera and IE5 don't display the page
correctly

See section 10.3.3 of the CSS2 spec, the "computed width" of the DIV is based on
the containing block width (that display area). That means the DIV's box is the
width of the window.

The 'overflow' property determines what happens when content overflows (as in
this case). Because the default is 'visible', the content that overflows is
displayed.

However, the DIV's box is _not_ expanded. That means the borders do _not_ go all
the way out to enclose the overflow text

See 11.1.1 for more information on 'overflow'
Status: RESOLVED → VERIFIED
Based on Troy's comments, marking as verified invalid.
*** Bug 14251 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.