Non-stop repainting of transform animation after CSS positioned mask enabled

RESOLVED DUPLICATE of bug 1234485

Status

()

RESOLVED DUPLICATE of bug 1234485
2 years ago
a year ago

People

(Reporter: epinal99-bugzilla2, Unassigned)

Tracking

({regression})

51 Branch
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51 wontfix)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
+++ This bug was initially created as a clone of Bug #1313332 +++

Steps to reproduce:

1) about:config > nglayout.debug.paint_flashing = true
2) Visit https://cityecho.ca/rentopedia and check the red radar spinner

Actual results:
Non-stop repainting of the rectangle layer containing the radar spinner.

Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=906c1f635c43ca24c685c7d1343d58eb0e4b0baf&tochange=bb8f2e88d99176437cdee6f4d50e6c5cd6a91f60

Astley Chen — Bug 1294660: Part 1 - enable CSS positioned mask on nightly and aurora. r=glandium


Is this non-stop repainting expected?
(Reporter)

Updated

2 years ago
Blocks: 1294660
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
status-firefox51: --- → affected
status-firefox52: --- → affected
Flags: needinfo?(aschen)
Keywords: css3 → regression

Comment 1

2 years ago
Yes, it's expected behavior. All OMTA in a masked box are disable.
Bug 1234485 is filed to improve this symptom, please refer to bug 1234485 comment 20. I am active working on it.
(In reply to C.J. Ku[:cjku](UTC+8) from comment #1)
> Yes, it's expected behavior. All OMTA in a masked box are disable.
> Bug 1234485 is filed to improve this symptom, please refer to bug 1234485
> comment 20. I am active working on it.

As CJ's reply, it's a known issue and being actively worked by CJ now.
Let's track the status on bug 1234485.
Thanks.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(aschen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1234485

Comment 3

2 years ago
By apply the patches in bug 1234485, OMTA works normally.

Comment 4

2 years ago
Created attachment 8805932 [details]
Paint mask on mask layer

Left hand side the original way, using basic layer manager, paint masked elements indirectly. FPS is jumpy, 45 in average. Right hand side paint mask onto mask layer, FPS is constant 60.
mask-image was enabled on nightly & aurora only, so this issue would be gone when 51 turns to beta. Will not uplift fix in bug 1234485 to 51.
status-firefox51: affected → wontfix
status-firefox52: affected → ---
Duplicate of this bug: 1313332
You need to log in before you can comment on or make changes to this bug.