Remove PContent::Msg_ReadPermissions sync message

RESOLVED DUPLICATE of bug 1337056

Status

()

Core
Widget
P4
normal
RESOLVED DUPLICATE of bug 1337056
a year ago
a year ago

People

(Reporter: mconley, Unassigned)

Tracking

(Blocks: 2 bugs)

50 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tpi:+)

When nsPermissionManager::Init fires in the content process, it sends a sync message "ReadPermissions" to the parent:

http://searchfox.org/mozilla-central/rev/445097654c1cc1098ee0171a29c439afe363a588/extensions/cookie/nsPermissionManager.cpp#795

It looks like this only occurs once the permission manager starts up, but it also looks like there's an API for refreshing permissions (nsIPermissionManager.refreshPermission). This was added in bug 1129315 for b2g, but I don't think it's called anymore. We might want to remove that.

We might be able to piggyback on the work going on in bug 1303096 to send permissions down along with the look-and-feel cache and preferences.

Updated

a year ago
Priority: -- → P4
Whiteboard: tpi:+
See Also: → bug 1337056

Comment 1

a year ago
(In reply to Mike Conley (:mconley) from comment #0)
> When nsPermissionManager::Init fires in the content process, it sends a sync
> message "ReadPermissions" to the parent:
> 
> http://searchfox.org/mozilla-central/rev/
> 445097654c1cc1098ee0171a29c439afe363a588/extensions/cookie/
> nsPermissionManager.cpp#795
> 
> It looks like this only occurs once the permission manager starts up, but it
> also looks like there's an API for refreshing permissions
> (nsIPermissionManager.refreshPermission). This was added in bug 1129315 for
> b2g, but I don't think it's called anymore. We might want to remove that.

Bug 1337056's fix is removing this sync message.  There's some evidence there so I'll dupe this way.

> We might be able to piggyback on the work going on in bug 1303096 to send
> permissions down along with the look-and-feel cache and preferences.

I actually have a better plan!  I'll post it to that bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
See Also: bug 1337056
Duplicate of bug: 1337056
You need to log in before you can comment on or make changes to this bug.