bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Master password dialog is not displayed if Thunderbird takes long to load

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: bege10, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

Start Thunderbird



Actual results:

If starting Thunderbird takes long (e.g. many extensions or full processor load by other processes) the dialog for master password is not displayed.


Expected results:

After starting master password dialog should be displayed.

Comment 1

2 years ago
which extesions?
how much time is "takes long"?
Flags: needinfo?(bege10)
(Reporter)

Comment 2

2 years ago
If it takes about 60 seconds to load Thunderbird the dialog does not show up.
I currently have about 50 activated extensions and everything works fine as long there is not high processor load by other processes.
Or if I additionally activate CuteButtons which slows down Thunderbird additonally.

Comment 3

2 years ago
On windows 7 using nightly build I cannot reproduce this, in my production profile with CuteButtons installed. I used CPUSTRES.exe to load the CPU with thunderbird process priority set at low. master password appeared after more than 60 seconds

So I suggest one of your many addons is causing this problem.

Updated

2 years ago
Component: Security → General
(Reporter)

Comment 4

2 years ago
After deactivating the extensions I step by step activated them again to find a possible cause for the problem. All I found is that Thunderbird now with all extensions activated needs only half the time to load than before and the dialog appears each time :-)
Perhaps there was an extension not correctly installed. You helped me to solve the problem in an unexpected way. Thank you very much.
Flags: needinfo?(bege10)
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.