Crash in npswf32_23_0_0_205.dll@0x3d55ad

VERIFIED FIXED

Status

Socorro
Symbols
--
critical
VERIFIED FIXED
a year ago
11 months ago

People

(Reporter: mccr8, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-1bcdc99e-cb28-42c3-8fda-e56452161027.
=============================================================

It looks like crashes with this version of Flash aren't being properly symbolized on crash-stats for some reason. This is the number 4 crash on the 10-26 Nightly, ahead of any other Flash crash. It is also the number 5 plugin crash on Firefox 49. I don't know how useful the symbols are, but at least they make it more obvious that it is a Flash crash.

Comment 1

a year ago
This is almost certainly due to not having symbols yet for the emergency Flash release on Wednesday. When they are 0-daying we often don't get symbols until after they have shipped. I can ping Adobe Monday if we don't see them.
Fwiw, there's also a spike of npswf64_23_0_0_205.dll@0x... in the v52 Top Crash list:
https://crash-stats.mozilla.com/topcrashers/?product=Firefox&version=52.0a1&days=7
Track 51+ as this is #5 top crash in 51 aurora.
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
tracking-firefox51: --- → +

Comment 4

a year ago
Next actions are for somebody to ping Adobe for symbols, if we're still missing them. That used to be Kairo's job: Sylvestre who owns that now?
Component: Flash (Adobe) → Symbols
Flags: needinfo?(sledru)
Product: External Software Affecting Firefox → Socorro
I wasn't aware we were doing that tbh.
Chris, do you have a clue? Thanks
Flags: needinfo?(sledru) → needinfo?(cpeterson)
(In reply to Sylvestre Ledru [:sylvestre] from comment #5)
> I wasn't aware we were doing that tbh.
> Chris, do you have a clue? Thanks

I don't know who is responsible for requesting Flash symbols from Adobe or incorporating them into Socorro.
Flags: needinfo?(cpeterson)
Do you know who is responsible for requesting Flash symbols from Adobe and uploading them to Socorro?
Flags: needinfo?(willkg)
Flags: needinfo?(ted)
Flags: needinfo?(peterbe)
Flags: needinfo?(chris.lonnen)
Flags: needinfo?(adrian)
The last person for Adobe to sign in was nitanwar@adobe.com
This account has symbol upload permissions.
Flags: needinfo?(willkg)
Flags: needinfo?(ted)
Flags: needinfo?(peterbe)
Flags: needinfo?(chris.lonnen)
Flags: needinfo?(adrian)
Hello Nidhi, we are missing Flash symbols for npswf64_23_0_0_205.dll, could you or someone else at Adobe upload them? Thanks!
Flags: needinfo?(nitanwar)
Nidhi replied to me personally, he had some problems with the switch from Persona to Google Sign-In that he managed to solve and he's going to upload the symbols tomorrow.
Flags: needinfo?(nitanwar)

Comment 11

a year ago
Hi,
I have added the symbols. Please check.
(In reply to nidhi tanwar from comment #11)
> Hi,
> I have added the symbols. Please check.

I've confirmed that the symbolication is working now by reprocessing bp-7e52c6a4-7f2c-46ae-aaa6-b03602161109.
Thank you!
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
I've also started reprocessing all the crash reports returned by this query, to avoid false alarms:
https://crash-stats.mozilla.com/search/?proto_signature=~npswf32_23_0_0_205.dll&proto_signature=~npswf32_23_0_0_207.dll&product=Firefox&version=50.0b&version=51.0a2&version=52.0a1&date=%3E%3D2016-05-09T11%3A10%3A15.000Z&date=%3C2016-11-09T11%3A10%3A15.000Z&_sort=-date&_facets=signature&_facets=proto_signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-signature

I've restricted it to 50, 51 and 52, as we're really close to releasing 50 (and because for 49 we have too many crashes to reprocess, not sure it's worth it).
The top crasher on https://crash-stats.mozilla.com/topcrashers/?product=Firefox&version=50.0b&days=7&process_type=plugin is now `F1398665248_____________________________`.
Status: RESOLVED → VERIFIED
status-firefox50: affected → ---
status-firefox51: affected → ---
status-firefox52: affected → ---
tracking-firefox51: + → ---
You need to log in before you can comment on or make changes to this bug.