Closed Bug 1313843 Opened 3 years ago Closed 3 years ago

One-off searches broken with keyword.enabled=false

Categories

(Firefox :: Search, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dqeswn, Unassigned)

References

Details

(Whiteboard: [fxsearch])

In this case clicking them is no different than pressing enter.

I mentioned this in bug 1309354, but it didn't get any recognition.

See also  Bug 1222378, which also presents itself with keyword.enabled=false.
Blocks: 1180944, 1262507
Seems to only happen for the heuristic result.  Maybe related to bug 1179153?
Assignee: nobody → adw
Severity: major → normal
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2
Whiteboard: [fxsearch]
No longer blocks: 1262507
See Also: → 1318070
Blocks: 1337003
Let's disable one-offs if keyword.enabled=false.
No longer blocks: 1337003
Priority: P2 → P3
Unassigning myself from non-P1 search bugs for now so I have more time for Photon bugs.
Assignee: adw → nobody
Status: ASSIGNED → NEW
Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170507100239

This issue is not reproducible anymore - searching by typing in the URL bar and then clicking on any one-off button is now possible when the preference keyword.enabled is set to false (verified on Ubuntu 16.04 and Mac OS X 10.11). 

Panos, is this expected in any way? Should the one-offs still be disabled when keyword.enabled=false?
Flags: needinfo?(past)
I can't reproduce it either, neither Bug 1222378. So I guess they were fixed, perhaps in bug 1318070.
(In reply to Simona B [:simonab ] from comment #4)
> Panos, is this expected in any way? Should the one-offs still be disabled
> when keyword.enabled=false?

It dose sound like this was fixed in another bug, so the workaround I suggested is not necessary. Thanks for checking again!
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(past)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.