If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Linux] Tried to install the latest version of Firefox on Linux Zorin, yet desktop icons launch previous old version.

RESOLVED WORKSFORME

Status

()

Firefox
Installer
RESOLVED WORKSFORME
a year ago
2 months ago

People

(Reporter: ERIC, Unassigned)

Tracking

49 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

Simple I DL'd the latest version, & yet the existing icons just launch old outdated version that came w/this version of Linux.


Actual results:

See above.


Expected results:

DUH! The NEWEST version should launch! This BS NEVER happens in Windows!

Updated

a year ago
Component: Untriaged → Application Update
OS: Unspecified → Linux
Product: Firefox → Toolkit
Hardware: Unspecified → x86_64
This is to say the least not normal and there are no other reports of this happening. Please provide all *.log and *.xml files in the install directory's updates directory.
Flags: needinfo?(TAURUS_43074)
(Reporter)

Comment 2

a year ago
I'm new to Linux, so, where do I find these?
Did Firefox come with your Linux installation?
Whiteboard: [CLOSEME 20161201]
(Reporter)

Comment 4

a year ago
Yes, it did. But, it was version 31-something. I upgraded to v. 49.0.02.
Most Linux distributions provide their own update mechanism and don't use the one provided by Mozilla. Which distribution are you using?
(Reporter)

Comment 6

a year ago
If mine has it, I have no clue where to find it.Which version of Linux am I using? I'm using Linux Zorin 9.1 64 bit.
OK... I've read a couple of posts that Linux Zorin has an outdated version of Firefox. It sounds like you downloaded the new version, etc. per
(In reply to ERIC from comment #0)
> Simple I DL'd the latest version, & yet the existing icons just launch old
> outdated version that came w/this version of Linux.

> DUH! The NEWEST version should launch! This BS NEVER happens in Windows!
Yep, Linux often requires more effort from the user when installing applications especially applications that are not part of the Linux distributions package manager.

To get help with installing Firefox (e.g. so they will launch, etc.) please check the support forums.
https://support.mozilla.org/en-US/questions/1029792

If you are unable to get the steps to work for you in that article please ask for help in the support forums.
https://support.mozilla.org/
Component: Application Update → Installer
Flags: needinfo?(TAURUS_43074)
Product: Toolkit → Firefox
Summary: Updated to latest version of Firefox, yet desktop icons launch previous old version. → [Linux] Tried to install the latest version of Firefox on Florin Linux, yet desktop icons launch previous old version.
Whiteboard: [CLOSEME 20161201]
(Reporter)

Updated

a year ago
Summary: [Linux] Tried to install the latest version of Firefox on Florin Linux, yet desktop icons launch previous old version. → [Linux] Tried to install the latest version of Firefox on Linux Zorin, yet desktop icons launch previous old version.
(Reporter)

Comment 8

a year ago
Hey Rob,

I just Dl'd Ubuntu 16.04 LTS & burned it to a DVD, rebooted, formatted, ditched Zorin, & the FF updated to the latest version NO ISSUES! & the icon ACTUALLY Launches the LATEST version! What a concept! DOH! :o ZORIN is the problem! Ubuntu RULES! I had the Zorin, & an older outdated version of Ubuntu, which would not install cause of some vid card drivers issues, so, I HAD to install the Zorin. ut the I DL'd the Ubuntu, & upgraded! :) Why though does even w/the updated Flash & FF does FF still give sgs soeties saying that Flash on certain pgs were being blocked & asking me to allow, even though, I had it set to ALWAYS activate?!

-Eric

Updated

2 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

2 months ago
Doesn't even matter now, I ditched Linux altogether last Oct./Nov.-WAY too many probs! I switched to Win 8.1 Pro, & have 0 of the probs I had w/Linux w/regards to installing anything. Linux has a long way to go yet! (All versions, even Ubuntu) It is not user-friendly enough for my tastes, & requires more deep-level computer knowledge than I have to use it & I don't have the patience for it!
You need to log in before you can comment on or make changes to this bug.