Some file changes were left out of the Autoland push

RESOLVED INVALID

Status

RESOLVED INVALID
2 years ago
5 months ago

People

(Reporter: ayg, Unassigned)

Tracking

Details

This review included files to C++ code and test files:

https://reviewboard.mozilla.org/r/88964/diff/2#index_header

But when autolanded, the test file changes were left out:

https://hg.mozilla.org/integration/autoland/rev/18ff1472dae9

Naturally, causing a backout due to unexpected passes.

???
On further investigation -- when trying to rebase on inbound locally, I found that my VCS produced the same result as a result of automatic merging.  There is no way Autoland could have detected this, it's just an inevitable occasional consequence of merging without testing the merged revision.  (In this case the problem is that my commit updated the test to expect the new behavior, and an intervening commit made the same test update without the code update, so it recorded unexpected fails that my commit now had to remove but didn't.)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Updated

5 months ago
Product: MozReview → Conduit
You need to log in before you can comment on or make changes to this bug.