|make pkg| fails with JavaScript error: resource://gre/modules/osfile/ospath_unix.jsm, line 90: TypeError: invalid path component

RESOLVED DUPLICATE of bug 1313726

Status

SeaMonkey
Build Config
RESOLVED DUPLICATE of bug 1313726
2 years ago
2 years ago

People

(Reporter: ewong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
getting this with latest trunk:

resource://gre/modules/ForgetAboutSite.jsm
resource://gre/modules/FormAutofill.jsm
resource://gre/modules/FormAutofillIntegration.jsm
resource://gre/modules/FormData.jsm
resource://gre/modules/FormHistory.jsm
resource://gre/modules/FormLikeFactory.jsm
resource://gre/modules/FxAccounts.jsm
resource://gre/modules/FxAccountsClient.jsm
resource://gre/modules/FxAccountsCommon.js
resource://gre/modules/FxAccountsConfig.jsm
resource://gre/modules/FxAccountsOAuthClient.jsm
resource://gre/modules/FxAccountsOAuthGrantClient.jsm
resource://gre/modules/FxAccountsProfile.jsm
JavaScript error: resource://gre/modules/osfile/ospath_unix.jsm, line 90: TypeError: invalid path component
resource://gre/modules/FxAccountsProfileClient.jsm
resource://gre/modules/FxAccountsPush.js
resource://gre/modules/FxAccountsStorage.jsm
resource://gre/modules/FxAccountsWebChannel.jsm
resource://gre/modules/GMPInstallManager.jsm
resource://gre/modules/GMPUtils.jsm
resource://gre/modules/Geometry.jsm
resource://gre/modules/History.jsm
(Reporter)

Comment 1

2 years ago
comment #0 is from the linux:

This is from the windows build:

NO_PKG_FILES="core bsdecho js js-config jscpucfg nsinstall viewer TestGtkEmbed elf-dynstr-gc mangle* maptsv* mfc* msdump* msmap* nm2tsv* nsinstall* res/samples res/throbber shlibsign* certutil* pk12util* BadCertServer* OCSPStaplingServer* GenerateOCSPResponse* chrome/chrome.rdf chrome/app-chrome.manifest chrome/overlayinfo components/compreg.dat components/xpti.dat content_unit_tests necko_unit_tests *.dSYM " \
c:/builds/slave/c-c/build/objdir/_virtualenv/Scripts/python.exe c:/builds/slave/c-c/build/mozilla/toolkit/mozapps/installer/packager.py -DMOZ_APP_NAME=seamonkey -DPREF_DIR=defaults/pref -DJAREXT= -DENABLE_TESTS=1 -DMOZ_ANGLE_RENDERER=1 -DMOZ_D3DCOMPILER_VISTA_DLL=d3dcompiler_47.dll -DNIGHTLY_BUILD=1 -DMOZ_CALENDAR=1 -DMOZ_PACKAGE_DEBUGQA=1 -D_MSC_VER=1900 -DMOZ_UPDATER=1 -DNECKO_WIFI=1 -DMOZ_BUNDLED_FONTS=1 -DMOZ_PACKAGE_MSVC_DLLS=1 -DMSVC_C_RUNTIME_DLL=vcruntime140.dll -DMSVC_CXX_RUNTIME_DLL=msvcp140.dll -DMOZ_PACKAGE_WIN_UCRT_DLLS=1 -DMOZ_SHARED_MOZGLUE=1 -DMOZ_CHILD_PROCESS_NAME=plugin-container.exe -DHAVE_MAKENSISU=1 -DDLL_PREFIX= -DDLL_SUFFIX=.dll -DBIN_SUFFIX=.exe -DDIR_MACOS= -DDIR_RESOURCES= -DMOZ_FOLD_LIBS=1 -DBINPATH=bin -DRESPATH=bin -DLPROJ_ROOT=en -DMOZ_ICU_VERSION=56 -DMOZ_ICU_DBG_SUFFIX= -DICU_DATA_FILE=icudt56l.dat -DMOZ_OMNIJAR=1 -DA11Y_LOG=1 -DACCESSIBILITY=1 -DBUILD_CTYPES=1 -DCROSS_COMPILE='' -DD_INO=d_ino -DE10S_TESTING_ONLY=1 -DEARLY_BETA_OR_EARLIER=1 -DENABLE_INTL_API=1 -DENABLE_MARIONETTE=1 -DENABLE_SYSTEM_EXTENSION_DIRS=1 -DENABLE_TESTS=1 -DEXPOSE_INTL_API=1 -DFIREFOX_VERSION=52.0a1 -DFORCE_PR_LOG=1 -DGTEST_HAS_RTTI=0 -DHAVE_64BIT_BUILD=1 -DHAVE_FORCEINLINE=1 -DHAVE_INTTYPES_H=1 -DHAVE_IO_H=1 -DHAVE_ISATTY=1 -DHAVE_LOCALECONV=1 -DHAVE_MALLOC_H=1 -DHAVE_SEH_EXCEPTIONS=1 -DHAVE_STDINT_H=1 -DHAVE_UINT64_T=1 -DJS_DEFAULT_JITREPORT_GRANULARITY=3 -DMALLOC_H='<malloc.h>' -DMALLOC_USABLE_SIZE_CONST_PTR=const -DMOZILLA_OFFICIAL=1 -DMOZILLA_UAVERSION='"52.0"' -DMOZILLA_VERSION='"52.0a1"' -DMOZILLA_VERSION_U=52.0a1 -DMOZ_APP_UA_NAME='""' -DMOZ_APP_UA_VERSION='"2.49a1"' -DMOZ_B2G_OS_NAME='""' -DMOZ_B2G_VERSION='"1.0.0"' -DMOZ_BINARY_EXTENSIONS=1 -DMOZ_BUILD_APP=../suite -DMOZ_BUNDLED_FONTS=1 -DMOZ_CONTENT_SANDBOX=1 -DMOZ_CRASHREPORTER=1 -DMOZ_CRASHREPORTER_ENABLE_PERCENT=100 -DMOZ_DATA_REPORTING=1 -DMOZ_DIRECTSHOW=1 -DMOZ_DISTRIBUTION_ID='"org.mozilla"' -DMOZ_DLL_SUFFIX='".dll"' -DMOZ_ENABLE_MASK_AS_SHORTHAND=1 -DMOZ_ENABLE_PROFILER_SPS=1 -DMOZ_ENABLE_SKIA=1 -DMOZ_FEEDS=1 -DMOZ_FFVPX=1 -DMOZ_FMP4=1 -DMOZ_GAMEPAD=1 -DMOZ_GMP_SANDBOX=1 -DMOZ_INSTRUMENT_EVENT_LOOP=1 -DMOZ_LIBAV_FFT=1 -DMOZ_LOGGING=1 -DMOZ_MACBUNDLE_ID=org.mozilla.seamonkey -DMOZ_MAPI_SUPPORT=1 -DMOZ_MEMORY=1 -DMOZ_MEMORY_WINDOWS=1 -DMOZ_MORK=1 -DMOZ_MSVC_STL_WRAP_RAISE=1 -DMOZ_PEERCONNECTION=1 -DMOZ_PERMISSIONS=1 -DMOZ_PLACES=1 -DMOZ_PROFILING=1 -DMOZ_RAW=1 -DMOZ_REPLACE_MALLOC=1 -DMOZ_SAMPLE_TYPE_FLOAT32=1 -DMOZ_SANDBOX=1 -DMOZ_SCTP=1 -DMOZ_SECUREELEMENT=1 -DMOZ_SEPARATE_MANIFEST_FOR_THEME_OVERRIDES=1 -DMOZ_SRTP=1 -DMOZ_STACKWALKING=1 -DMOZ_STATIC_JS=1 -DMOZ_SUITE=1 -DMOZ_TREE_CAIRO=1 -DMOZ_TREE_PIXMAN=1 -DMOZ_UPDATER=1 -DMOZ_UPDATE_CHANNEL=default -DMOZ_USER_DIR='"Mozilla"' -DMOZ_VORBIS=1 -DMOZ_VPX_ERROR_CONCEALMENT=1 -DMOZ_VPX_NO_MEM_REPORTING=1 -DMOZ_VTUNE=1 -DMOZ_WEBGL_CONFORMANT=1 -DMOZ_WEBM_ENCODER=1 -DMOZ_WEBRTC=1 -DMOZ_WEBRTC_ASSERT_ALWAYS=1 -DMOZ_WEBRTC_SIGNALING=1 -DMOZ_WEBSPEECH=1 -DMOZ_WEBSPEECH_TEST_BACKEND=1 -DMOZ_WMF=1 -DMOZ_XUL=1 -DMSVC_HAS_DIA_SDK=1 -DNIGHTLY_BUILD=1 -DNOMINMAX=1 -DNO_NSPR_10_SUPPORT=1 -DNS_ENABLE_TSF=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DSPIDERMONKEY_PROMISE=1 -DSTATIC_JS_API=1 -DSTDC_HEADERS=1 -DTARGET_XPCOM_ABI='"x86_64-msvc"' -DUSE_SKIA=1 -DUSE_SKIA_GPU=1 -DU_STATIC_IMPLEMENTATION=1 -DU_USING_ICU_NAMESPACE=0 -DVPX_X86_ASM=1 -DWIN32=1 -DWIN32_LEAN_AND_MEAN=1 -DWINVER=0x502 -DXP_WIN=1 -DXP_WIN32=1 -DX_DISPLAY_MISSING=1 -D_AMD64_=1 -D_CRT_NONSTDC_NO_WARNINGS=1 -D_CRT_SECURE_NO_WARNINGS=1 -D_USE_MATH_DEFINES=1 -D_WIN32_IE=0x0603 -D_WIN32_WINNT=0x502 -D_WINDOWS=1 -DAB_CD=en-US \
	--format omni \
	--removals c:/builds/slave/c-c/build/suite/installer/removed-files.in \
	 \
	 \
	 \
	 \
	--optimizejars \
	--disable-compression \
	 \
	package-manifest ../../dist ../../dist/seamonkey \
	--non-resource defaults/messenger/mailViews.dat defaults/profile/panels.rdf defaults/profile/mimeTypes.rdf defaults/profile/chrome/userChrome-example.css defaults/profile/chrome/userContent-example.css 
Error: c:\builds\slave\c-c\build\objdir\suite\installer\package-manifest:133: Missing file(s): bin/components/dom_telephony.xpt
Traceback (most recent call last):
  File "c:/builds/slave/c-c/build/mozilla/toolkit/mozapps/installer/packager.py", line 415, in <module>
    main()
  File "c:/builds/slave/c-c/build/mozilla/toolkit/mozapps/installer/packager.py", line 367, in main
    copier.add(mozpath.join(respath, 'removed-files'), removals)
  File "d:\mozillabuild\python\Lib\contextlib.py", line 24, in __exit__
    self.gen.next()
  File "c:\builds\slave\c-c\build\mozilla\python\mozbuild\mozpack\errors.py", line 131, in accumulate
    raise AccumulatedErrors()
mozpack.errors.AccumulatedErrors
c:/builds/slave/c-c/build/mozilla/toolkit/mozapps/installer/packager.mk:41: recipe for target 'stage-package' failed
mozmake.exe[3]: *** [stage-package] Error 1
mozmake.exe[3]: Leaving directory 'c:/builds/slave/c-c/build/objdir/suite/installer'
(Reporter)

Comment 2

2 years ago
Created attachment 8805893 [details] [diff] [review]
proposed patch (v1)

this patch fixes the missing dom_telephony.xpt part, but it doesn't
fix the "TypeError: invalid path component".
Attachment #8805893 - Flags: review?(iann_bugzilla)
ewong this should be fixed. Please check again.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1313726

Updated

2 years ago
Attachment #8805893 - Flags: review?(iann_bugzilla)
(Reporter)

Comment 4

2 years ago
(In reply to Frank-Rainer Grahl from comment #3)
> ewong this should be fixed. Please check again.
> 
> *** This bug has been marked as a duplicate of bug 1313726 ***

Nope. It's still busted with the same thing.  I'm wondering if this is the results of bug 1313670?
You need to log in before you can comment on or make changes to this bug.