Intermittent dom/base/test/test_intersectionobservers.html | rootBounds should is set to null for cross-origin observations [observe subframe]

RESOLVED FIXED in Firefox 54

Status

()

Core
DOM
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: Treeherder Bug Filer, Assigned: tobytailor)

Tracking

({intermittent-failure})

unspecified
mozilla55
intermittent-failure
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox52 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 fixed, firefox55 fixed)

Details

(Whiteboard: [stockwell fixed])

Attachments

(3 attachments, 3 obsolete attachments)

Comment 1

2 years ago
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 6
* autoland: 6
* mozilla-central: 3

Platform breakdown:
* android-4-3-armv7-api15: 10
* linux64: 4
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2016-11-01&endday=2016-11-01&tree=all

Comment 2

2 years ago
16 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 10
* mozilla-inbound: 6

Platform breakdown:
* android-4-3-armv7-api15: 16

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2016-11-02&endday=2016-11-02&tree=all

Comment 3

2 years ago
64 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 29
* autoland: 27
* mozilla-central: 6
* try: 2

Platform breakdown:
* android-4-3-armv7-api15: 57
* linux64: 4
* linux32: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2016-10-31&endday=2016-11-06&tree=all
New test, added in bug 1243846.
Blocks: 1243846
Flags: needinfo?(tschneider)

Comment 5

2 years ago
16 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 9
* mozilla-inbound: 5
* mozilla-central: 2

Platform breakdown:
* android-4-3-armv7-api15: 15
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2016-11-08&endday=2016-11-08&tree=all

Comment 6

2 years ago
71 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 30
* autoland: 30
* mozilla-central: 6
* try: 4
* graphics: 1

Platform breakdown:
* android-4-3-armv7-api15: 58
* linux64: 8
* linux32: 3
* windowsxp: 1
* windows7-32-vm: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2016-11-07&endday=2016-11-13&tree=all

Comment 7

2 years ago
19 failures in 113 pushes (0.168 failures/push) were associated with this bug yesterday.  

Repository breakdown:
* autoland: 7
* mozilla-inbound: 6
* mozilla-aurora: 2
* graphics: 2
* try: 1
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api15: 10
* linux64: 7
* windows8-64: 1
* windows7-32-vm: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2016-11-18&endday=2016-11-18&tree=all

Comment 8

2 years ago
74 failures in 715 pushes (0.103 failures/push) were associated with this bug in the last 7 days. 

This is the #33 most frequent failure this week. 

** This failure happened more than 50 times this week! Resolving this bug is a high priority. **

Repository breakdown:
* mozilla-inbound: 33
* autoland: 23
* mozilla-aurora: 7
* mozilla-central: 4
* graphics: 4
* try: 3

Platform breakdown:
* android-4-3-armv7-api15: 52
* linux64: 17
* linux32: 2
* windowsxp: 1
* windows8-64: 1
* windows7-32-vm: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2016-11-14&endday=2016-11-20&tree=all

Updated

2 years ago
See Also: → bug 1313970, bug 1313927

Comment 10

2 years ago
58 failures in 623 pushes (0.093 failures/push) were associated with this bug in the last 7 days. 

This is the #21 most frequent failure this week. 

** This failure happened more than 50 times this week! Resolving this bug is a high priority. **

Repository breakdown:
* mozilla-inbound: 22
* autoland: 20
* mozilla-aurora: 10
* mozilla-central: 4
* try: 2

Platform breakdown:
* android-4-3-armv7-api15: 41
* linux64: 13
* windows7-32-vm: 2
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2016-11-21&endday=2016-11-27&tree=all

Comment 11

2 years ago
17 failures in 110 pushes (0.155 failures/push) were associated with this bug yesterday.  

Repository breakdown:
* autoland: 7
* mozilla-inbound: 6
* mozilla-central: 2
* try: 1
* mozilla-aurora: 1

Platform breakdown:
* android-4-3-armv7-api15: 14
* linux64: 2
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2016-11-28&endday=2016-11-28&tree=all

Comment 12

2 years ago
25 failures in 694 pushes (0.036 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* autoland: 14
* mozilla-inbound: 6
* try: 2
* mozilla-central: 2
* mozilla-aurora: 1

Platform breakdown:
* android-4-3-armv7-api15: 19
* linux64: 5
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2016-11-28&endday=2016-12-04&tree=all

Comment 13

2 years ago
6 failures in 305 pushes (0.02 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* try: 2
* mozilla-inbound: 2
* autoland: 2

Platform breakdown:
* linux64: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2016-12-26&endday=2017-01-01&tree=all
No recent failures.
Flags: needinfo?(tschneider)
This is back again now that bug 1321865 has re-landed.
Flags: needinfo?(tschneider)
Back with a vengeance. I would say that this needs to be fixed before we can consider uplifting to Aurora.
(Assignee)

Comment 17

a year ago
Created attachment 8855186 [details] [diff] [review]
Fix racing condition in intersection observer tests

Fixing intermittent failures due to a racing condition.
Flags: needinfo?(tschneider)
(Assignee)

Updated

a year ago
Keywords: checkin-needed
Blocks: 1321865
No longer blocks: 1243846

Comment 18

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/45d3d0f2d62a
Intermittent dom/base/test/test_intersectionobservers.html | rootBounds should is set to null for cross-origin observations [observe subframe]. r=me
Keywords: checkin-needed
seems that doesn;t fix this - https://treeherder.mozilla.org/logviewer.html#?job_id=89177187&repo=mozilla-inbound after landing of this patch :(
Flags: needinfo?(tschneider)

Comment 20

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/45d3d0f2d62a
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Bah, leave-open should have been set on this given comment 19.
Assignee: nobody → tschneider
Status: RESOLVED → REOPENED
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
status-firefox54: --- → affected
status-firefox55: fixed → affected
status-firefox-esr52: --- → unaffected
Resolution: FIXED → ---
Target Milestone: mozilla55 → ---
126 failures in 170 pushes (0.741 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 63
* autoland: 32
* try: 13
* mozilla-central: 10
* graphics: 8

Platform breakdown:
* linux64: 60
* linux32: 37
* osx-10-10: 12
* windows7-32-vm: 8
* windows8-64: 7
* windows2012-64: 1
* windows2012-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2017-04-06&endday=2017-04-06&tree=all
See Also: → bug 1324135
with 126 failures in 1 day, I would really like to see this fixed ASAP- In fact this is a new test turned on, so I am going to back this out until we get this looked at.  In bug 1353461 where we turned this on there is no mention of a try push or other data to indicate that this was even tested.

Comment 24

a year ago
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/35af33f46d94
backout bug 1321865 for extremely high test failure rate. r=me
Whiteboard: [stockwell disabled]
121 failures in 185 pushes (0.654 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 61
* mozilla-inbound: 27
* oak: 11
* graphics: 11
* mozilla-central: 7
* try: 4

Platform breakdown:
* linux64: 47
* linux32: 37
* windows8-64: 19
* windows7-32-vm: 9
* osx-10-10: 9

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2017-04-07&endday=2017-04-07&tree=all
311 failures in 867 pushes (0.359 failures/push) were associated with this bug in the last 7 days. 

This is the #4 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **  

Repository breakdown:
* autoland: 115
* mozilla-inbound: 113
* mozilla-central: 28
* graphics: 22
* try: 21
* oak: 12

Platform breakdown:
* linux64: 137
* linux32: 96
* windows8-64: 31
* osx-10-10: 26
* windows7-32-vm: 19
* windows2012-64: 1
* windows2012-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2017-04-03&endday=2017-04-09&tree=all
(Assignee)

Comment 28

a year ago
I was finally able to reproduce this reliably. The problem was that all our iframe tests load the same iframe content, which calls postMessage on onLoad. Not all of those tests consume the postMessage event tho. That leads to a racing conditions where the test that actually does consume the event receives messages from previous tests.
Flags: needinfo?(tschneider)
(Assignee)

Comment 29

a year ago
Created attachment 8857572 [details] [diff] [review]
Avoid racing condition by making sure postMessage events are consumed by the correct tests.

Fixes described issue. Try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=aa08a5a24e2a38861ae19dae375d00d9a774a189
Attachment #8855186 - Attachment is obsolete: true
(Assignee)

Comment 31

a year ago
That will happen if we re-land bug 1321865.
(Assignee)

Updated

a year ago
Keywords: checkin-needed
Comment on attachment 8857572 [details] [diff] [review]
Avoid racing condition by making sure postMessage events are consumed by the correct tests.

LGTM. Thx!
Attachment #8857572 - Flags: review+

Comment 33

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/05af3a08fb6f
Avoid racing condition by making sure postMessage events are consumed by the correct tests. r=smaug
Keywords: checkin-needed

Comment 34

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/05af3a08fb6f
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
status-firefox55: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
(Assignee)

Updated

a year ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 35

a year ago
Created attachment 8858432 [details] [diff] [review]
List intersectionobserver_cross_domain_iframe.html as support file in mochitest.ini

We forgot to list intersectionobserver_cross_domain_iframe.html under the support-files section in mochitest.ini leading to timeout issues when the iframe can't be loaded (not on all platforms tho...).
(Assignee)

Comment 36

a year ago
Created attachment 8858433 [details] [diff] [review]
List intersectionobserver_cross_domain_iframe.html as support file in mochitest.ini

Should also fix a typo while on it.
Attachment #8858432 - Attachment is obsolete: true
(Assignee)

Updated

a year ago
Attachment #8858433 - Flags: review?(bugs)

Updated

a year ago
Attachment #8858433 - Flags: review?(bugs) → review+
22 failures in 894 pushes (0.025 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* graphics: 12
* autoland: 6
* try: 4

Platform breakdown:
* linux64: 11
* linux32: 8
* windows7-32-vm: 2
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1313972&startday=2017-04-10&endday=2017-04-16&tree=all

Comment 40

a year ago
Pushed by philringnalda@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0e09a3206a83
List intersectionobserver_cross_domain_iframe.html as support file in mochitest.ini, r=jet
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/0e09a3206a83
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → FIXED
status-firefox54: affected → disabled
(Assignee)

Comment 42

a year ago
Comment on attachment 8857572 [details] [diff] [review]
Avoid racing condition by making sure postMessage events are consumed by the correct tests.

Approval Request Comment
[Feature/Bug causing the regression]: 1321865
[User impact if declined]: No test coverage
[Is this code covered by automated tests?]: It is one
[Has the fix been verified in Nightly?]: Yes
[Is the change risky?]: No
Attachment #8857572 - Flags: approval-mozilla-beta?
(Assignee)

Comment 43

a year ago
Comment on attachment 8857572 [details] [diff] [review]
Avoid racing condition by making sure postMessage events are consumed by the correct tests.

not part of the build
Attachment #8857572 - Flags: approval-mozilla-beta?
(Assignee)

Comment 44

a year ago
Created attachment 8864625 [details] [diff] [review]
Patch for beta uplift
(Assignee)

Updated

a year ago
Blocks: 1362168
(Assignee)

Updated

a year ago
Whiteboard: [stockwell disabled] → [stockwell disabled] [checkin-needed-beta]
status-firefox54: disabled → affected

Comment 45

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/c097727dc385
status-firefox54: affected → fixed
Flags: in-testsuite+
Whiteboard: [stockwell disabled] [checkin-needed-beta] → [stockwell fixed]
(Assignee)

Comment 46

a year ago
Created attachment 8864713 [details] [diff] [review]
Patch for beta uplift

Had an issue when merging back the try-only changes from https://treeherder.mozilla.org/#/jobs?repo=try&revision=95acba62d571c397d08bed74cf963d9f700f9e7e. Should be fixed now.
Attachment #8864625 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.