Closed Bug 1314061 Opened 3 years ago Closed 3 years ago

Crash in mozilla::dom::CheckSimilarOrigin

Categories

(Core :: Layout, defect, critical)

Unspecified
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 1314032

People

(Reporter: wsmwk, Unassigned)

References

Details

(Keywords: crash)

I just crashed loading and attempting to scroll http://bgr.com/2016/10/31/ios-10-download-update/

It's #4 crash in a 1 day period of crash-stats. https://crash-stats.mozilla.com/search/?product=Firefox&version=52.0a1&date=%3E%3D2016-10-30T16%3A43%3A39.000Z&date=%3C2016-10-31T16%3A43%3A39.000Z&_sort=-date&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-signature

Crashes began with yesterday's build  20161031030202 - https://crash-stats.mozilla.com/signature/?product=Firefox&signature=mozilla%3A%3Adom%3A%3ACheckSimilarOrigin&date=%3E%3D2016-10-24T16%3A42%3A00.000Z&date=%3C2016-10-31T16%3A42%3A00.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_sort=-date&page=1#summary

bp-1f00e272-87b1-430e-a1b2-f3f0c2161031.
0 	xul.dll	mozilla::dom::CheckSimilarOrigin	dom/base/DOMIntersectionObserver.cpp:210
1 	xul.dll	mozilla::dom::DOMIntersectionObserver::Update(nsIDocument*, double)	dom/base/DOMIntersectionObserver.cpp:351
2 	xul.dll	nsDocument::UpdateIntersectionObservations()	dom/base/nsDocument.cpp:12396
3 	xul.dll	nsRefreshDriver::Tick(__int64, mozilla::TimeStamp)	layout/base/nsRefreshDriver.cpp:1921
4 	xul.dll	mozilla::RefreshDriverTimer::TickDriver(nsRefreshDriver*, __int64, mozilla::TimeStamp)	layout/base/nsRefreshDriver.cpp:326
5 	xul.dll	mozilla::RefreshDriverTimer::TickRefreshDrivers(__int64, mozilla::TimeStamp, nsTArray<RefPtr<nsRefreshDriver> >&)	layout/base/nsRefreshDriver.cpp:295
6 	xul.dll	mozilla::RefreshDriverTimer::Tick(__int64, mozilla::TimeStamp)	layout/base/nsRefreshDriver.cpp:317
7 	xul.dll	mozilla::VsyncRefreshDriverTimer::RunRefreshDrivers(mozilla::TimeStamp)	layout/base/nsRefreshDriver.cpp:663
8 	xul.dll	mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::TickRefreshDriver(mozilla::TimeStamp)	layout/base/nsRefreshDriver.cpp:583
9 	xul.dll	mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::NotifyVsync(mozilla::TimeStamp)	layout/base/nsRefreshDriver.cpp:501
Component: DOM → Layout
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1314032
Crash Signature: [@ mozilla::dom::CheckSimilarOrigin]
You need to log in before you can comment on or make changes to this bug.