If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add-on icon not showing in Thunderbird 50.0b2 on Windows 8.1

RESOLVED FIXED in Thunderbird 52.0

Status

Thunderbird
Theme
RESOLVED FIXED
11 months ago
10 months ago

People

(Reporter: Óvári, Assigned: Paenglab)

Tracking

50 Branch
Thunderbird 52.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 2 obsolete attachments)

(Reporter)

Description

11 months ago
Created attachment 8806294 [details]
Add-ons icon.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161028101142

Steps to reproduce:

Please see attachment showing screenshot created using Linux Mint 18.

Circled is the icon for Add-on and is showing correctly in TB50.0b2 with Linux Mint 18.

The icon for Add-on is *not* showing in TB50.0b2 with Windows 8.1.
Seems to be a regression as this icon was showing in TB45 with Windows 8.1.

Thank you

Comment 1

11 months ago
Shows for me with TB50.0b1 and 50.0b3 on Windows 7 and also in TB 52 (Daily).
(Assignee)

Comment 2

11 months ago
But only with scaling factor 1. Toolkit removed the icon which is used for the higher DPI settings.
(Assignee)

Comment 3

11 months ago
Created attachment 8806464 [details] [diff] [review]
1314248.patch

This patch uses the SVG icon for all scales. The only downside is, this icon is green and not blue.

Jörg, you're on Windows, so I'm asking you to review this simple patch.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8806464 - Flags: review?(jorgk)

Comment 4

11 months ago
Comment on attachment 8806464 [details] [diff] [review]
1314248.patch

Looks good. The icon is green now instead of blue for Daily.
Attachment #8806464 - Flags: review?(jorgk) → review+
(Assignee)

Updated

11 months ago
Keywords: checkin-needed

Comment 5

11 months ago
https://hg.mozilla.org/comm-central/rev/d1955b8fbe8644eff457c8cfec3666e759e2beee
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 52.0

Comment 6

11 months ago
Have you noticed that at least in Daily, the icon on the tab is blue, the icon on the Hamburger menu is green. So you click a green icon to get a blue one ;-)

Is that intentional? Before both were blue.
Flags: needinfo?(richard.marti)
(Assignee)

Comment 7

11 months ago
Yes, I know about this. The problem is, that the tab icon is hardcoded in XUL file and only Windows Vista to 10 uses the blue icon, all other the green. I'm looking if I can add an override to the green SVG icon. Then it would also look better on higher scales. I had no time to file a bug yet.
Flags: needinfo?(richard.marti)
(Assignee)

Updated

11 months ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

11 months ago
Created attachment 8807943 [details] [diff] [review]
follow-up.patch

I found a solution painting the SVG icon blue for the non-XP Windows versions. The icon was also backward to the tab icon.
Attachment #8807943 - Flags: review?(jorgk)

Comment 9

11 months ago
This is really quite confusing. Here the situation on Win 7 (non-XP):
FF: Tab icon: blue, ears top and left.
FF: Hamburger menu icon: grey, ears top and right. Hmm.

TB: Tab icon: blue, ears top and left.
TB: Hamburger menu icon: with patch: blue, ears top and left.
    Without patch: green, ears top and right.

Note that the generic add-on icon in the add-ons manager is *green* with ears top and right.

Personally, I'd prefer green with ears top and right everywhere. Wouldn't that make sense? The blue reverted icon makes no sense to me.

Wouldn't it me better to change the tab icon and leave the Hamburger menu as it was?

If we were to use a blue icon, why do we mirror the green one and paint it blue? Besides, the blue isn't right since the blue tab icon has a gradient. I'll attach a blue icon with gradient with ears top/left.

Comment 10

11 months ago
Created attachment 8807977 [details]
extensionGeneric3.svg - blue with gradient, ears top and left.
(Assignee)

Comment 11

11 months ago
(In reply to Jorg K (GMT+1) from comment #9)
> This is really quite confusing. Here the situation on Win 7 (non-XP):
> FF: Tab icon: blue, ears top and left.
> FF: Hamburger menu icon: grey, ears top and right. Hmm.

Would be worth for a FX bug. ;)

> TB: Tab icon: blue, ears top and left.
> TB: Hamburger menu icon: with patch: blue, ears top and left.
>     Without patch: green, ears top and right.
> 
> Note that the generic add-on icon in the add-ons manager is *green* with
> ears top and right.
> 
> Personally, I'd prefer green with ears top and right everywhere. Wouldn't
> that make sense? The blue reverted icon makes no sense to me.
> 
> Wouldn't it me better to change the tab icon and leave the Hamburger menu as
> it was?

Yes, then we have everywhere a green icon with ears on the top/right.

> If we were to use a blue icon, why do we mirror the green one and paint it
> blue? Besides, the blue isn't right since the blue tab icon has a gradient.
> I'll attach a blue icon with gradient with ears top/left.

The issue was for higher DPI screens we used a icon (blue) which was removed from tree and the replacement is now the SVG icon.
(Assignee)

Comment 12

11 months ago
Created attachment 8807983 [details] [diff] [review]
follow-up.patch

This patch exchanges every reference to extensionGeneric-16.png with extensionGeneric.svg. This is the only solution we can exchange the Add-on tab icon which is hardcoded in toolkit.
Attachment #8807943 - Attachment is obsolete: true
Attachment #8807943 - Flags: review?(jorgk)
Attachment #8807983 - Flags: review?(jorgk)

Comment 13

11 months ago
Comment on attachment 8807983 [details] [diff] [review]
follow-up.patch

Yes, that makes the icon on the tab green which is consistent with the Hamburger menu and the generic add-on icon.

Two questions arise:
1) Can we dare to be different from our FF friends?
2) The blue FF icon looks better on a non-active tab than the green icon.
   Can we live with that?

I'll leave it to you. The alternative would be to use our own blue SVG for the Hamburger menu.

Oh, didn't you say it's green on all platforms apart from Windows > XP. Then the green is probably OK.

If you decide to go with this, please land with DONTBUILD. I don't think the world will come to a stop if this doesn't get into the next Daily build ;-)
Attachment #8807983 - Flags: review?(jorgk) → review+
(Assignee)

Comment 14

11 months ago
Created attachment 8808333 [details] [diff] [review]
follow-up.patch enhanced solution

I'm using now our own icon with a bit better visibility on Win7 Aero. This icon is now used on all platforms.

(In reply to Jorg K (GMT+1) from comment #13)
> Yes, that makes the icon on the tab green which is consistent with the
> Hamburger menu and the generic add-on icon.
> 
> Two questions arise:
> 1) Can we dare to be different from our FF friends?

I would say yes. We have already a different titlebar color on Win10 for example.

> 2) The blue FF icon looks better on a non-active tab than the green icon.
>    Can we live with that?

On Win7 Classic the green is visible, the blue not. Where always exists a background which is almost the same as the icon has.
Attachment #8808333 - Flags: review?(jorgk)

Comment 15

11 months ago
Created attachment 8808358 [details]
Comparing TB to FF on Win 7 Aero

Hmm, thanks for the effort, but it's not looking crash-hot ;-(
I can't even see the hole/opening on the left. If you look with a magnifier, you can see that the background colour doesn't enter the hole.

Updated

11 months ago
Attachment #8807983 - Attachment is obsolete: true

Comment 16

11 months ago
Comment on attachment 8808333 [details] [diff] [review]
follow-up.patch enhanced solution

Review of attachment 8808333 [details] [diff] [review]:
-----------------------------------------------------------------

We've discussed on IRC to remove the stroke since it causes the gap/hole/opening to be filled.

r+ with this change and the one below, r=jorgk.

::: mail/themes/windows/mail/primaryToolbar.css
@@ +336,5 @@
>    font-style: italic;
>  }
>  
>  #appmenu_addons {
> +  list-style-image: url("chrome://mozapps/skin/extensions/extensionGeneric-16.png");

Can you please refer this directly to the new SVG file. I find the referral to something that is overridden confusing. In this case also change the Linux file that uses the PNG at the moment.
Attachment #8808333 - Flags: review?(jorgk) → review+
(Assignee)

Comment 17

11 months ago
Comments addressed.
https://hg.mozilla.org/comm-central/rev/f31996b31a32cf18476a1d49d5511a5604e09aa6
Status: REOPENED → RESOLVED
Last Resolved: 11 months ago11 months ago
Resolution: --- → FIXED

Comment 18

11 months ago
(In reply to Richard Marti (:Paenglab) from comment #17)
> Comments addressed.
Great. Thanks for the patience, I think what we have now is best ;-)
Component: Untriaged → Theme
You need to log in before you can comment on or make changes to this bug.