Closed Bug 1314647 Opened 5 years ago Closed 5 years ago

[e10s] <select> preserves active state when I release mouse over the list scrollbar

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox49 --- wontfix
firefox50 --- wontfix
firefox51 --- wontfix
firefox52 --- wontfix
firefox53 --- fixed

People

(Reporter: pauly, Assigned: enndeakin)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

[Note]:
- follow-up of bug 1256313

[Affected versions]:
- 49.0.2, 50b11, 51.0a2 (2016-11-02), 52.0a1 (2016-11-02)

[Affected platforms]:
- all

[Steps to reproduce]:
1. Open https://bugzilla.mozilla.org/attachment.cgi?id=8730207 (testcase from bug 1256313)
2. Hover mouse over the <select>'s dropmarker, hold left mouse button   [drop-down list will open]
3. Hover mouse over the scrollbar
4. Release left mouse button
5. Move mouse to urlbar and click in urlbar

[Expected result]:
- Select doesn't have :active pseudoclass

[Actual result]:
- Select has :active pseudoclass

[Regression range]:
- not a recent regression, reproducible on Fx 45
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attached patch Clear state on mouseup (obsolete) — Splinter Review
Attachment #8808993 - Flags: review?(mconley)
Comment on attachment 8808993 [details] [diff] [review]
Clear state on mouseup

Going to fix some bugs first.
Attachment #8808993 - Flags: review?(mconley)
I added the listeners on the window instead. This way mouseup will work outside the popup.
Attachment #8809835 - Flags: review?(mconley)
Comment on attachment 8809835 [details] [diff] [review]
Clear state on mouseup

Review of attachment 8809835 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM - thanks Enn!
Attachment #8809835 - Flags: review?(mconley) → review+
(Might be good to add a test for this, fwiw)
Attachment #8808993 - Attachment is obsolete: true
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a925f48bcc82
Backed out changeset deec8c2ba931 for eslint failures
https://hg.mozilla.org/mozilla-central/rev/74a7f0bc633a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Duplicate of this bug: 1326689
You need to log in before you can comment on or make changes to this bug.